This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 657928 - [abrt] Zim-0.49-1.fc14: attachmentbrowser.py:604:set_current_folder:KeyError: 'active'
[abrt] Zim-0.49-1.fc14: attachmentbrowser.py:604:set_current_folder:KeyError:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:4522250b
:
: 666882 667000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-28 13:47 EST by benvdh
Modified: 2011-02-24 01:28 EST (History)
7 users (show)

See Also:
Fixed In Version: Zim-0.50-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 01:28:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (635 bytes, text/plain)
2010-11-28 13:47 EST, benvdh
no flags Details
zim -D output (4.08 KB, text/plain)
2010-11-30 14:02 EST, benvdh
no flags Details

  None (edit)
Description benvdh 2010-11-28 13:47:42 EST
abrt version: 1.1.14
architecture: i686
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.6-48.fc14.i686
package: Zim-0.49-1.fc14
reason: attachmentbrowser.py:604:set_current_folder:KeyError: 'active'
release: Fedora release 14 (Laughlin)
time: 1290969780
uid: 500

backtrace
-----
attachmentbrowser.py:604:set_current_folder:KeyError: 'active'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/attachmentbrowser.py", line 677, in on_open_page
    self.set_current_folder(str(self.plugin.ui.notebook.get_attachments_dir(page)+os.sep))
  File "/usr/lib/python2.7/site-packages/zim/plugins/attachmentbrowser.py", line 604, in set_current_folder
    if (self.plugin.uistate['active']):
KeyError: 'active'

Local variables in innermost frame:
path:
self: <AttachmentBrowserPluginWidget object at 0x9db670c (zim+plugins+attachmentbrowser+AttachmentBrowserPluginWidget at 0x9be1570)>

How to reproduce
-----
1. Just started Zim and the default notebook opened.
2. Then ABRT says it crashed, although zim is still open and working
Comment 1 benvdh 2010-11-28 13:47:44 EST
Created attachment 463364 [details]
File: backtrace
Comment 2 Robin Lee 2010-11-29 05:56:58 EST
Do you meat this bug every time you start Zim?

Please run 'zim -D' and attach the output here.

It's a bug apparently in the Attachment Browser plugin. You can just take off this plugin if you are annoyed by the ABRT report.

I cannot reproduce this bug with your steps. Upstream has a similar bug report: 
https://bugs.launchpad.net/zim/+bug/664556 . Please open another notebook with your Zim already started, to see whether you can reproduce this bug.
Comment 3 benvdh 2010-11-30 14:02:53 EST
Created attachment 463805 [details]
zim -D output

Hi, 

Yes, this crash occurs everytime I start Zim. Attached you will find the output of running 'zim -D.' It also occurred when I tried to open a new notebook, so I could reproduce it when I opened a different notebook. Only when I open another notebook a different line number in the python script is mentioned. Instead of line 604, line 607 is shown in the error message instead.

I hope this helps,

Kind regards,

Ben
Comment 4 Renich Bon Ciric 2010-12-26 16:38:20 EST
Package: Zim-0.49-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open Zim
2. Try to view Help > Contents

Comment
-----
It didn't really crash... it just showed this crash report...
Comment 5 Renich Bon Ciric 2010-12-30 04:49:43 EST
Package: Zim-0.49-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Enable all plugins

Comment
-----
This keeps happening but nothing crashes.
Comment 6 Renich Bon Ciric 2011-01-01 14:32:40 EST
Package: Zim-0.49-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start Zym (all plugins activated)


Comment
-----
It didn't crash... just a bug report...
Comment 7 Robin Lee 2011-01-03 19:58:32 EST
Marked 'fix committed' upstream.
Comment 8 Robin Lee 2011-01-03 21:31:49 EST
*** Bug 667000 has been marked as a duplicate of this bug. ***
Comment 9 Esteban Contreras-Vazquez 2011-01-14 14:22:26 EST
Package: Zim-0.49-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opened with gnome-Do
2.
3.
Comment 10 Petr Tomasek 2011-01-16 12:29:53 EST
Package: Zim-0.49-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. start Zim
2. choose "notebook"
3. crash reportedly happens (but the notebook still opens and Zim works...)
Comment 11 peter 2011-02-09 04:57:45 EST
Package: Zim-0.49-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Just opened Zim Desktop Wiki
2. I get the message that it crashed
3. Zim seems to work anyway
Comment 12 Robin Lee 2011-02-15 12:02:46 EST
*** Bug 666882 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2011-02-15 12:28:31 EST
Zim-0.50-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Zim-0.50-1.fc14
Comment 14 Fedora Update System 2011-02-15 16:26:02 EST
Zim-0.50-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Zim'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Zim-0.50-1.fc14
Comment 15 Fedora Update System 2011-02-24 01:28:14 EST
Zim-0.50-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.