Bug 667000 - [abrt] Zim-0.49-1.fc14: attachmentbrowser.py:607:set_current_folder:KeyError: 'active'
[abrt] Zim-0.49-1.fc14: attachmentbrowser.py:607:set_current_folder:KeyError:...
Status: CLOSED DUPLICATE of bug 657928
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:69476cf6
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-03 21:26 EST by Renich Bon Ciric
Modified: 2011-01-03 21:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-03 21:31:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (681 bytes, text/plain)
2011-01-03 21:26 EST, Renich Bon Ciric
no flags Details

  None (edit)
Description Renich Bon Ciric 2011-01-03 21:26:49 EST
abrt version: 1.1.14
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/zim -D
comment: This happens at startup
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.10-74.fc14.x86_64
package: Zim-0.49-1.fc14
reason: attachmentbrowser.py:607:set_current_folder:KeyError: 'active'
release: Fedora release 14 (Laughlin)
How to reproduce: 1. Start Zim with all plugins active with: zim -D
time: 1294107962
uid: 500

backtrace
-----
attachmentbrowser.py:607:set_current_folder:KeyError: 'active'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/attachmentbrowser.py", line 677, in on_open_page
    self.set_current_folder(str(self.plugin.ui.notebook.get_attachments_dir(page)+os.sep))
  File "/usr/lib/python2.7/site-packages/zim/plugins/attachmentbrowser.py", line 607, in set_current_folder
    if (self.plugin.uistate['active'] ):
KeyError: 'active'

Local variables in innermost frame:
path: '/home/renich/Notes/CloudSigma/test/subpage'
self: <AttachmentBrowserPluginWidget object at 0x23615f0 (zim+plugins+attachmentbrowser+AttachmentBrowserPluginWidget at 0x23e0200)>
Comment 1 Renich Bon Ciric 2011-01-03 21:26:51 EST
Created attachment 471575 [details]
File: backtrace
Comment 2 Robin Lee 2011-01-03 21:31:49 EST

*** This bug has been marked as a duplicate of bug 657928 ***

Note You need to log in before you can comment on or make changes to this bug.