Bug 658043 - File conflicts between wordnet multilib packages in Optional repo
Summary: File conflicts between wordnet multilib packages in Optional repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: wordnet
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: i18n Engineering List
URL:
Whiteboard:
Depends On:
Blocks: 644778
TreeView+ depends on / blocked
 
Reported: 2010-11-29 08:32 UTC by Alexander Todorov
Modified: 2014-01-21 06:19 UTC (History)
7 users (show)

Fixed In Version: wordnet-3.0-14.el6
Doc Type: Bug Fix
Doc Text:
Cause Installing both wordnet packages compiled for 32-bit and 64-bit system on the same host. Consequence The later packages could not been installed because of conflicting files. Fix Auxiliary files in conflict have been removed from the packages. Result wordnet package is now multi-architecture safe.
Clone Of: 644778
: 658118 (view as bug list)
Environment:
Last Closed: 2012-06-20 14:34:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix (1.07 KB, patch)
2010-11-29 12:50 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0932 0 normal SHIPPED_LIVE wordnet bug fix update 2012-06-19 21:12:26 UTC

Description Alexander Todorov 2010-11-29 08:32:18 UTC
+++ This bug was initially created as a clone of Bug #644778 +++

Description of problem:
There is a file conflict between many packages (i386 and x86_64) in the optional repository for the Workstation variant, x86_64 arch.

Version-Release number of selected component (if applicable):
RHEL6.0-20100922.1 
yum-3.2.27-14.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do yum localinstall *.rpm inside the optional repository
2.
3.
  
Actual results:
Multiple file conflicts, transaction aborted.

Expected results:
No conflicts

Additional info:
WIll post the entire log in the next comment.

--- Additional comment from atodorov@redhat.com on 2010-10-20 12:05:41 EEST ---

Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/share/doc/wordnet-3.0/html/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
  file /usr/share/doc/wordnet-3.0/pdf/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
  file /usr/share/doc/wordnet-3.0/ps/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
--- Additional comment from atodorov@redhat.com on 2010-10-20 14:02:24 EEST ---

For the conflicting documentation files see bug #449731 (RHEL4) - it requested that rpm ignores file conflicts under /usr/share/doc to work around several multilib conflicts on ia64.

Comment 1 Petr Pisar 2010-11-29 12:50:28 UTC
Created attachment 463476 [details]
Fix

Remove unneeded and conflicting Makefiles* from documentation directory.

Comment 4 Suzanne Yeghiayan 2011-02-15 21:45:46 UTC
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.

Comment 13 Petr Pisar 2012-03-05 14:34:27 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Installing both wordnet packages compiled for 32-bit and 64-bit
    system on the same host.
Consequence
    The later packages could not been installed because of
    conflicting files.
Fix
    Auxiliary files in conflict have been removed from the packages.
Result
    wordnet package is now multi-architecture safe.

Comment 17 errata-xmlrpc 2012-06-20 14:34:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0932.html


Note You need to log in before you can comment on or make changes to this bug.