Bug 644778 - File conflicts between multilib packages in Optional repo
File conflicts between multilib packages in Optional repo
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
: Reopened, Tracking
Depends On: 658034 658036 658038 658041 658048 658049 658053 658055 658056 658061 914635 658039 658043 658045 658046 658051 658057 658058 658059 658060 658062 658064 658065 658067 676607 702988
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-20 05:04 EDT by Alexander Todorov
Modified: 2014-12-15 13:43 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some packages in the Optional repositories on RHN have multilib file conflicts. Consequently, these packages cannot have both the primary architecture (e.g. x86_64) and secondary architecture (e.g. i686) copies of the package installed on the same machine simultaneously. To work around this, install only one copy of the conflicting package.
Story Points: ---
Clone Of:
: 658034 658036 658038 658039 658041 658043 658045 658046 658048 658049 658051 658053 658055 658056 658057 658058 658059 658060 658061 658062 658064 658065 658067 (view as bug list)
Environment:
Last Closed: 2014-09-17 07:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2010-10-20 05:04:42 EDT
Description of problem:
There is a file conflict between many packages (i386 and x86_64) in the optional repository for the Workstation variant, x86_64 arch.

Version-Release number of selected component (if applicable):
RHEL6.0-20100922.1 
yum-3.2.27-14.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do yum localinstall *.rpm inside the optional repository
2.
3.
  
Actual results:
Multiple file conflicts, transaction aborted.

Expected results:
No conflicts

Additional info:
WIll post the entire log in the next comment.
Comment 1 Alexander Todorov 2010-10-20 05:05:41 EDT
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/share/doc/libisofs-devel-0.6.32/html/structiso__stream.html conflicts between attempted installs of libisofs-devel-0.6.32-1.el6.i686 and libisofs-devel-0.6.32-1.el6.x86_64
  file /usr/share/doc/libisofs-devel-0.6.32/html/structiso__stream__coll__graph.map conflicts between attempted installs of libisofs-devel-0.6.32-1.el6.i686 and libisofs-devel-0.6.32-1.el6.x86_64
  file /usr/share/doc/libisofs-devel-0.6.32/html/structiso__stream__coll__graph.png conflicts between attempted installs of libisofs-devel-0.6.32-1.el6.i686 and libisofs-devel-0.6.32-1.el6.x86_64
  file /usr/bin/vigra-config conflicts between attempted installs of vigra-devel-1.6.0-2.1.el6.i686 and vigra-devel-1.6.0-2.1.el6.x86_64
  file /usr/share/gtk-doc/html/gnome-disk-utility/index.html conflicts between attempted installs of gnome-disk-utility-devel-2.30.1-2.el6.x86_64 and gnome-disk-utility-devel-2.30.1-2.el6.i686
  file /usr/bin/camlp4 conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4boot conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4o conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4of conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4oof conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4orf conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4r conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/camlp4rf conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/bin/mkcamlp4 conflicts between attempted installs of ocaml-camlp4-devel-3.11.2-2.el6.x86_64 and ocaml-camlp4-devel-3.11.2-2.el6.i686
  file /usr/share/gtk-doc/html/gladeui/GladeWidget.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/gtk-doc/html/gladeui/catalogintro.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/gtk-doc/html/gladeui/ix01.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/gtk-doc/html/gladeui/properties.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/gtk-doc/html/gladeui/pythonsupport.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/gtk-doc/html/gladeui/widgetclasses.html conflicts between attempted installs of glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64 and glade3-libgladeui-devel-3.6.7-2.1.el6.i686
  file /usr/share/doc/wordnet-3.0/html/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
  file /usr/share/doc/wordnet-3.0/pdf/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
  file /usr/share/doc/wordnet-3.0/ps/Makefile conflicts between attempted installs of wordnet-3.0-13.el6.x86_64 and wordnet-3.0-13.el6.i686
  file /usr/include/isc/platform.h conflicts between attempted installs of bind-devel-32:9.7.0-5.P2.el6.x86_64 and bind-devel-32:9.7.0-5.P2.el6.i686
  file /usr/include/gssglue/gssapi/gssapi.h conflicts between attempted installs of libgssglue-devel-0.1-8.1.el6.i686 and libgssglue-devel-0.1-8.1.el6.x86_64
  file /usr/bin/ocamlbrowser conflicts between attempted installs of ocaml-labltk-devel-3.11.2-2.el6.i686 and ocaml-labltk-devel-3.11.2-2.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-binding-tool.1.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-CreateFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-DeleteFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-DetailedError.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-Error.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-OtherFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-Vehicle.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-hierarchy.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-DescribedPair.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-DescribedPoint.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-ExtendedDescribedPoint.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-Pair.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-Point.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-StructWithVariant.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/index.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/ix01.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/bin/ocaml-xgettext conflicts between attempted installs of ocaml-gettext-devel-0.3.3-3.5.el6.x86_64 and ocaml-gettext-devel-0.3.3-3.5.el6.i686
  file /usr/include/event-config.h conflicts between attempted installs of libevent-devel-1.4.13-1.el6.x86_64 and libevent-devel-1.4.13-1.el6.i686
  file /usr/share/doc/libevent-devel-1.4.13/latex/doxygen.sty conflicts between attempted installs of libevent-devel-1.4.13-1.el6.x86_64 and libevent-devel-1.4.13-1.el6.i686
  file /usr/share/doc/libevent-devel-1.4.13/latex/refman.tex conflicts between attempted installs of libevent-devel-1.4.13-1.el6.x86_64 and libevent-devel-1.4.13-1.el6.i686
  file /usr/share/doc/libevent-devel-1.4.13/sample/Makefile conflicts between attempted installs of libevent-devel-1.4.13-1.el6.x86_64 and libevent-devel-1.4.13-1.el6.i686
  file /usr/share/gtk-doc/html/udisks/Adapter.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/Device.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/Expander.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/Port.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/UDisks.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/index.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/ix01.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/udisks-daemon.8.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/udisks-tcp-bridge.1.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/udisks.1.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/udisks/udisks.7.html conflicts between attempted installs of udisks-devel-1.0.1-2.el6.x86_64 and udisks-devel-1.0.1-2.el6.i686
  file /usr/share/gtk-doc/html/devkit-power/Device.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/DeviceKit-power.7.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/Power.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/QoS.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/devkit-power-daemon.8.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/devkit-power.1.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/index.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/share/gtk-doc/html/devkit-power/ix01.html conflicts between attempted installs of DeviceKit-power-devel-014-1.el6.i686 and DeviceKit-power-devel-014-1.el6.x86_64
  file /usr/bin/redland-config conflicts between attempted installs of redland-devel-1.0.7-11.el6.x86_64 and redland-devel-1.0.7-11.el6.i686
  file /usr/bin/autotrace-config conflicts between attempted installs of autotrace-devel-0.31.1-25.el6.x86_64 and autotrace-devel-0.31.1-25.el6.i686
  file /usr/bin/ksba-config conflicts between attempted installs of libksba-devel-1.0.7-1.el6.x86_64 and libksba-devel-1.0.7-1.el6.i686
  file /usr/share/gtk-doc/html/libucil/ch01.html conflicts between attempted installs of unicap-devel-0.9.5-4.el6.x86_64 and unicap-devel-0.9.5-4.el6.i686
  file /usr/share/gtk-doc/html/libunicap/ch01.html conflicts between attempted installs of unicap-devel-0.9.5-4.el6.x86_64 and unicap-devel-0.9.5-4.el6.i686
  file /usr/share/gtk-doc/html/libunicapgtk/UnicapgtkDeviceSelection.html conflicts between attempted installs of unicap-devel-0.9.5-4.el6.x86_64 and unicap-devel-0.9.5-4.el6.i686
  file /usr/share/gtk-doc/html/libunicapgtk/ch01.html conflicts between attempted installs of unicap-devel-0.9.5-4.el6.x86_64 and unicap-devel-0.9.5-4.el6.i686
  file /usr/share/opencv/OpenCVConfig.cmake conflicts between attempted installs of opencv-devel-2.0.0-9.el6.i686 and opencv-devel-2.0.0-9.el6.x86_64
  file /usr/bin/rasqal-config conflicts between attempted installs of rasqal-devel-0.9.15-6.1.el6.i686 and rasqal-devel-0.9.15-6.1.el6.x86_64
  file /usr/bin/uuid-config conflicts between attempted installs of uuid-devel-1.6.1-10.el6.i686 and uuid-devel-1.6.1-10.el6.x86_64
  file /usr/include/libvisual-0.4/libvisual/lvconfig.h conflicts between attempted installs of libvisual-devel-0.4.0-9.1.el6.x86_64 and libvisual-devel-0.4.0-9.1.el6.i686
  file /usr/include/dovecot/config.h conflicts between attempted installs of dovecot-devel-1:2.0-0.10.beta6.20100630.el6.x86_64 and dovecot-devel-1:2.0-0.10.beta6.20100630.el6.i686
  file /usr/include/libmapi/version.h conflicts between attempted installs of openchange-devel-0.9-7.el6.i686 and openchange-devel-0.9-7.el6.x86_64
  file /usr/share/doc/openchange-devel-0.9/libmapi/version_8h.html conflicts between attempted installs of openchange-devel-0.9-7.el6.i686 and openchange-devel-0.9-7.el6.x86_64
  file /usr/share/man/man3/version.h.3.gz conflicts between attempted installs of openchange-devel-0.9-7.el6.i686 and openchange-devel-0.9-7.el6.x86_64

Error Summary
-------------
Comment 2 Alexander Todorov 2010-10-20 05:10:54 EDT
The conflicting packages are:
libisofs-devel
vigra-devel
gnome-disk-utility-devel
ocaml-camlp4-devel
glade3-libgladeui-devel
wordnet
bind-devel
libgssglue-devel
ocaml-labltk-devel
eggdbus-devel
ocaml-gettext-devel
libevent-devel
udisks-devel
DeviceKit-power-devel
redland-devel
autotrace-devel
libksba-devel
unicap-devel
opencv-devel
rasqal-devel
uuid-devel
libvisual-devel
dovecot-devel
openchange-devel


The conflicting files are mostly documentation but there are couple of files under /usr/bin and some development header files.
Comment 3 Jan Stodola 2010-10-20 06:21:22 EDT
Conflicting packages for ComputeNode variant, 86_64 arch:

autotrace-devel-0.31.1-25.el6
bind-devel-32:9.7.0-5.P2.el6
DeviceKit-power-devel-014-1.el6
eggdbus-devel-0.6-3.el6
glade3-libgladeui-devel-3.6.7-2.1.el6
gnome-disk-utility-devel-2.30.1-2.el6
libevent-devel-1.4.13-1.el6
libgssglue-devel-0.1-8.1.el6
libisofs-devel-0.6.32-1.el6
libksba-devel-1.0.7-1.el6
libvisual-devel-0.4.0-9.1.el6
ocaml-camlp4-devel-3.11.2-2.el6
ocaml-gettext-devel-0.3.3-3.5.el6
ocaml-labltk-devel-3.11.2-2.el6
rasqal-devel-0.9.15-6.1.el6
redland-devel-1.0.7-11.el6
udisks-devel-1.0.1-2.el6
uuid-devel-1.6.1-10.el6
Comment 4 Martin Banas 2010-10-20 06:26:01 EDT
Conflicting packages are also in x86_64/Client, see below:

autotrace-devel-0.31.1-25.el6.x86_64
bind-devel-32:9.7.0-5.P2.el6.x86_64
DeviceKit-power-devel-014-1.el6.i686
eggdbus-devel-0.6-3.el6.i686
glade3-libgladeui-devel-3.6.7-2.1.el6.x86_64
gnome-disk-utility-devel-2.30.1-2.el6.x86_64
libevent-devel-1.4.13-1.el6.x86_64
libgssglue-devel-0.1-8.1.el6.i686
libisofs-devel-0.6.32-1.el6.i686
libksba-devel-1.0.7-1.el6.x86_64
libvisual-devel-0.4.0-9.1.el6.x86_64
ocaml-camlp4-devel-3.11.2-2.el6.x86_64
ocaml-gettext-devel-0.3.3-3.5.el6.x86_64
ocaml-labltk-devel-3.11.2-2.el6.i686
openchange-devel-0.9-7.el6.i686
opencv-devel-2.0.0-9.el6.i686
rasqal-devel-0.9.15-6.1.el6.i686
redland-devel-1.0.7-11.el6.x86_64
udisks-devel-1.0.1-2.el6.x86_64
unicap-devel-0.9.5-4.el6.x86_64
uuid-devel-1.6.1-10.el6.i686
vigra-devel-1.6.0-2.1.el6.x86_64
wordnet-3.0-13.el6.i686
Comment 5 Alexander Todorov 2010-10-20 07:02:24 EDT
WebServer (x86_64) is also affected. 

Martin and Jan,
can you check if we see this issue on ppc64 and s390x? I suspect the answer will be yes.


For the conflicting documentation files see bug #449731 (RHEL4) - it requested that rpm ignores file conflicts under /usr/share/doc to work around several multilib conflicts on ia64.
Comment 6 Jan Stodola 2010-10-20 07:19:38 EDT
Conflicting packages on s390x:

autotrace-devel-0.31.1-25.el6
DeviceKit-power-devel-014-1.el6
dovecot-devel-1:2.0-0.10.beta6.20100630.el6
eggdbus-devel-0.6-3.el6
glade3-libgladeui-devel-3.6.7-2.1.el6
gnome-disk-utility-devel-2.30.1-2.el6
libevent-devel-1.4.13-1.el6
libgssglue-devel-0.1-8.1.el6
libksba-devel-1.0.7-1.el6
libvisual-devel-0.4.0-9.1.el6
opencv-devel-2.0.0-9.el6
rasqal-devel-0.9.15-6.1.el6
redland-devel-1.0.7-11.el6
udisks-devel-1.0.1-2.el6
unicap-devel-0.9.5-4.el6
uuid-devel-1.6.1-10.el6
vigra-devel-1.6.0-2.1.el6
wordnet-3.0-13.el6
Comment 7 Martin Banas 2010-10-20 07:29:42 EDT
Conflicting packages on ppc64:

autotrace-devel-0.31.1-25.el6.ppc
bind-devel-32:9.7.0-5.P2.el6.ppc64
DeviceKit-power-devel-014-1.el6.ppc
dovecot-devel-1:2.0-0.10.beta6.20100630.el6.ppc
eggdbus-devel-0.6-3.el6.ppc64
fontforge-devel-20090622-2.1.el6.ppc
glade3-libgladeui-devel-3.6.7-2.1.el6.ppc64
gnome-disk-utility-devel-2.30.1-2.el6.ppc
libevent-devel-1.4.13-1.el6.ppc
libgssglue-devel-0.1-8.1.el6.ppc
libksba-devel-1.0.7-1.el6.ppc
libvisual-devel-0.4.0-9.1.el6.ppc
ocaml-camlp4-devel-3.11.2-2.el6.ppc64
ocaml-gettext-devel-0.3.3-3.5.el6.ppc
ocaml-labltk-devel-3.11.2-2.el6.ppc
openchange-devel-0.9-7.el6.ppc
opencv-devel-2.0.0-9.el6.ppc64
rasqal-devel-0.9.15-6.1.el6.ppc64
redland-devel-1.0.7-11.el6.ppc64
udisks-devel-1.0.1-2.el6.ppc
unicap-devel-0.9.5-4.el6.ppc64
uuid-devel-1.6.1-10.el6.ppc64
vigra-devel-1.6.0-2.1.el6.ppc64
wordnet-3.0-13.el6.ppc
Comment 8 Alexander Todorov 2010-10-20 09:00:13 EDT
Update summary - ppc64 and s390x are also affected.
Comment 9 seth vidal 2010-10-20 09:24:13 EDT
If these pkgs have conflicting files it is a packaging bug, not a yum bug.

Open these bugs with the relevant pkgs.
Comment 15 Alexander Todorov 2010-12-01 08:35:02 EST
Dennis,
individual bugs have been filed for different components. No work required here. We can leave this open for tracking or close it as not a bug if you wish.
Comment 16 Panu Matilainen 2010-12-02 16:02:42 EST
Happened to stumble on this largely accidentally... 

The "permit doc conflicts" hack is not coming back in rpm, it was only done for RHEL 4 + 5 because mid-release rpm rebase was much stricter than the one those releases started with, and fixing all the packages was simply not an option.

Many of the above conflicts are on Doxygen-generated developer documentation. For those, perhaps the cleanest option is to split the documentation into a noarch foo-apidocs sub-package. Doxygen-generated documentation usually only differs between architectures due to timestamps added into (html) content and slight image generation differences which make no difference for documentation usability, and making them noarch (which wasn't possible in older RHEL-versions) allows the same package to be shared across all architectures, potentially saving diskspace and bandwidth.
Comment 17 Leonard den Ottolander 2010-12-02 18:12:34 EST
Could it be that there is a difference in the value of
%_binary_filedigest_algorithm
in the different build environments? That could cause rpm not to recognize the identical files as being identical as the checksums cannot be matched.
Comment 18 Leonard den Ottolander 2010-12-02 19:48:43 EST
You can disregard my previous remark. Although the errors are similar this is an entirely different issue. Sorry for the noise.
Comment 25 Dennis Gregorovic 2011-04-18 17:08:42 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
  Some packages in the Optional repositories on RHN have multilib file conflicts.

Consequence
  Packages that have multilib file conflicts cannot have both the primary architecture (e.g. x86_64) and secondary architecture (e.g. i686) copies on the package installed on the same machine simultaneously.

Workaround
  To work around this, install only one copy of the conflicting package.

Result
  This may limit the ability to run certain secondary architecture applications or to build against secondary architecture libraries.
Comment 27 Ryan Lerch 2011-05-10 01:17:48 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,11 +1 @@
-Cause
+Some packages in the Optional repositories on RHN have multilib file conflicts. Consequently, these packages cannot have both the primary architecture (e.g. x86_64) and secondary architecture (e.g. i686) copies of the package installed on the same machine simultaneously. To work around this, install only one copy of the conflicting package.-  Some packages in the Optional repositories on RHN have multilib file conflicts.
-
-Consequence
-  Packages that have multilib file conflicts cannot have both the primary architecture (e.g. x86_64) and secondary architecture (e.g. i686) copies on the package installed on the same machine simultaneously.
-
-Workaround
-  To work around this, install only one copy of the conflicting package.
-
-Result
-  This may limit the ability to run certain secondary architecture applications or to build against secondary architecture libraries.
Comment 30 Suzanne Yeghiayan 2012-05-18 16:46:04 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 34 Lubos Kocman 2014-09-17 07:26:42 EDT
Hello

I'm closing this obsolete tracker bug. Please deal with issues on the individual component level if necessary. There is quite a lot of these in my queue.

Thanks for understanding

Lubos
rel-eng

Note You need to log in before you can comment on or make changes to this bug.