Bug 658048 - File conflicts between eggbus-devel multilib packages in Optional repo
Summary: File conflicts between eggbus-devel multilib packages in Optional repo
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: eggdbus
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 644778
TreeView+ depends on / blocked
 
Reported: 2010-11-29 08:46 UTC by Alexander Todorov
Modified: 2017-12-06 11:04 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 644778
Environment:
Last Closed: 2017-12-06 11:04:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Todorov 2010-11-29 08:46:08 UTC
+++ This bug was initially created as a clone of Bug #644778 +++

Description of problem:
There is a file conflict between many packages (i386 and x86_64) in the optional repository for the Workstation variant, x86_64 arch.

Version-Release number of selected component (if applicable):
RHEL6.0-20100922.1 
yum-3.2.27-14.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do yum localinstall *.rpm inside the optional repository
2.
3.
  
Actual results:
Multiple file conflicts, transaction aborted.

Expected results:
No conflicts

Additional info:
WIll post the entire log in the next comment.

--- Additional comment from atodorov@redhat.com on 2010-10-20 12:05:41 EEST ---

Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-binding-tool.1.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-CreateFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-DeleteFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-DetailedError.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-Error.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-OtherFlags.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-enummain-Vehicle.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-hierarchy.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-DescribedPair.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-DescribedPoint.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-ExtendedDescribedPoint.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-Pair.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-Point.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/eggdbus-structmain-StructWithVariant.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/index.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64
  file /usr/share/gtk-doc/html/eggdbus/ix01.html conflicts between attempted installs of eggdbus-devel-0.6-3.el6.i686 and eggdbus-devel-0.6-3.el6.x86_64

--- Additional comment from atodorov@redhat.com on 2010-10-20 14:02:24 EEST ---

For the conflicting documentation files see bug #449731 (RHEL4) - it requested that rpm ignores file conflicts under /usr/share/doc to work around several multilib conflicts on ia64.

Comment 1 RHEL Program Management 2011-01-07 16:04:40 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 2 RHEL Program Management 2011-07-06 01:17:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Jan Kurik 2017-12-06 11:04:48 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.