Bug 658062 - File conflicts between uuid-devel multilib packages in Optional repo
Summary: File conflicts between uuid-devel multilib packages in Optional repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dennis Gregorovic
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 644778 756082 761078
TreeView+ depends on / blocked
 
Reported: 2010-11-29 09:04 UTC by Alexander Todorov
Modified: 2013-03-04 20:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 644778
: 914635 (view as bug list)
Environment:
Last Closed: 2012-06-20 14:52:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0971 normal SHIPPED_LIVE redhat-release enhancement update for Red Hat Enterprise Linux 6.3 2012-06-19 19:50:37 UTC

Description Alexander Todorov 2010-11-29 09:04:31 UTC
+++ This bug was initially created as a clone of Bug #644778 +++

Description of problem:
There is a file conflict between many packages (i386 and x86_64) in the optional repository for the Workstation variant, x86_64 arch.

Version-Release number of selected component (if applicable):
RHEL6.0-20100922.1 
yum-3.2.27-14.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do yum localinstall *.rpm inside the optional repository
2.
3.
  
Actual results:
Multiple file conflicts, transaction aborted.

Expected results:
No conflicts

Additional info:
WIll post the entire log in the next comment.

--- Additional comment from atodorov@redhat.com on 2010-10-20 12:05:41 EEST ---

Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/bin/uuid-config conflicts between attempted installs of uuid-devel-1.6.1-10.el6.i686 and uuid-devel-1.6.1-10.el6.x86_64
-------------


--- Additional comment from atodorov@redhat.com on 2010-10-20 14:02:24 EEST ---

For the conflicting documentation files see bug #449731 (RHEL4) - it requested that rpm ignores file conflicts under /usr/share/doc to work around several multilib conflicts on ia64.

Comment 1 RHEL Product and Program Management 2011-01-07 15:35:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 2 Michal Hlavinka 2011-02-01 16:47:21 UTC
I'm going to close this one CANTIFX. Conflicting file is script that should be called to get compiler flags. These flags are different for 32bit and 64bit, but I'm not aware of any way how to check what version of flags calling script wants.

Comment 3 Alexander Todorov 2011-02-09 07:20:54 UTC
How about changing the script name to something line uuid-config-$arch ? 

Another possible fix is to remove the multilib package like we did in bug #658039.

Comment 4 Michal Hlavinka 2011-02-09 08:14:17 UTC
(In reply to comment #3)
> How about changing the script name to something line uuid-config-$arch ? 

I don't know how this could help? Other packages are calling uuid-config during their build time, you'd have to patch all of them to use new name and even learn them how to decide what name they really need.

Comment 5 Alexander Todorov 2011-02-09 09:18:09 UTC
Moving to releng then. 

Dennis,
can you check if we can remove the multilib package?

Comment 6 Dennis Gregorovic 2011-02-09 17:53:19 UTC
What about a wrapper script as described here?
http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks#Multiarch.2C_binaries_and_compilation_scripts

We try to avoid adding packages to the multiarch blacklist whenever possible.

Comment 15 Alexander Todorov 2012-04-02 15:09:30 UTC
uuid-devel 32bit has been removed from Workstation x86_64. 

yum localinstall uuid* in the optional directory completed without an error.

Comment 16 errata-xmlrpc 2012-06-20 14:52:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0971.html


Note You need to log in before you can comment on or make changes to this bug.