Bug 658304 - [abrt] recovery of CSV file causes crash
[abrt] recovery of CSV file causes crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
abrt_hash:7b3269e922ec538f30add9c11f0...
:
: 659358 661383 661384 663480 663885 665639 701849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 17:48 EST by compphreak
Modified: 2011-05-09 00:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: libreoffice-3.3.2.2-7.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-28 15:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (66.03 KB, text/plain)
2010-11-29 17:48 EST, compphreak
no flags Details

  None (edit)
Description compphreak 2010-11-29 17:48:12 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc file:///home/D-Car/aircrackcaptures/firstrip-01.csv
component: openoffice.org
crash_function: Font::Font
executable: /usr/lib64/openoffice.org3/program/scalc.bin
kernel: 2.6.35.6-48.fc14.x86_64
package: openoffice.org-calc-1:3.3.0-15.2.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1291028835
uid: 500

comment
-----
displays everytime i login

How to reproduce
-----
Happens every bootup
Comment 1 compphreak 2010-11-29 17:48:15 EST
Created attachment 463600 [details]
File: backtrace
Comment 2 David Tardon 2010-11-30 01:55:28 EST
This happens because you have quickstarter on and calc crashed sometime in the past when a CSV file had been opened. Because of the quickstarter, oo.o starts automatically with desktop session and tries to recover the file. And it stumbles over a situation that cannot happen during normal opening .-)

You should be able to avoid subsequent crashes that by starting oo.o normally and then pressing no in the recovery dialog. Alternatively, if you haven't made any custom settings that you don't want to lose, you can remove ~/.openoffice.org/3/user/registrymodifications.xcu .
Comment 3 David Tardon 2010-12-01 07:31:21 EST
fix will be in 3.3.0-17.3.fc14
Comment 4 Caolan McNamara 2010-12-02 11:13:34 EST
*** Bug 659358 has been marked as a duplicate of this bug. ***
Comment 5 David Tardon 2010-12-08 12:42:03 EST
*** Bug 661383 has been marked as a duplicate of this bug. ***
Comment 6 David Tardon 2010-12-08 12:42:22 EST
*** Bug 661384 has been marked as a duplicate of this bug. ***
Comment 7 Qi Changhai 2010-12-11 02:55:38 EST
Package: openoffice.org-calc-1:3.3.0-17.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Startup openoffice.org as non-root(as root all is ok)
2.
3.
Comment 8 Fedora Update System 2010-12-15 03:51:46 EST
openoffice.org-3.3.0-18.1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.1.fc14
Comment 9 David Tardon 2010-12-16 00:07:46 EST
*** Bug 663480 has been marked as a duplicate of this bug. ***
Comment 10 David Tardon 2010-12-17 02:56:45 EST
*** Bug 663885 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-12-17 03:45:33 EST
openoffice.org-3.3.0-18.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.1.fc14
Comment 12 Fedora Update System 2010-12-21 07:09:30 EST
openoffice.org-3.3.0-18.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-18.2.fc14
Comment 13 David Tardon 2010-12-25 09:28:41 EST
*** Bug 665639 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2010-12-28 15:59:20 EST
openoffice.org-3.3.0-18.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 David Tardon 2011-05-04 04:46:46 EDT
*** Bug 701849 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2011-05-05 00:25:03 EDT
libreoffice-3.3.2.2-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-7.fc15
Comment 17 Fedora Update System 2011-05-09 00:04:17 EDT
libreoffice-3.3.2.2-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.