Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 658386 - Patch to allow mbkernel and mbargs to be read from /etc/sysconfig/kernel
Summary: Patch to allow mbkernel and mbargs to be read from /etc/sysconfig/kernel
Keywords:
Status: CLOSED DUPLICATE of bug 658387
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: rawhide
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-30 08:38 UTC by W. Michael Petullo
Modified: 2010-12-21 05:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-21 05:34:23 UTC
Type: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2010-11-30 08:38:10 UTC
Description of problem:
New-kernel-pkg has support for mbkernel and mbargs. However, there is no way to set these variables other than by using command line options. This does not support a single kernel which boots both on bare metal and from within a hypervisor such as Xen (upcoming Xen kernels will have this capability). I have attached a patch that reads mbkernel and mbargs from /etc/sysconfig/kernel:HYPERVISOR and :HYPERVISOR_ARGS, respectively. The allows a single kernel package to be installed to boot with or without a hypervisor.

This is a requirement for the Xen Pvops Dom0 feature that will be proposed for Fedora 15 (http://fedoraproject.org/wiki/Features/XenPvopsDom0).

Version-Release number of selected component (if applicable):
Git d3ca5734c2ca2f3dce2591d06ed609b9bfee756a

Comment 1 W. Michael Petullo 2010-12-21 05:34:23 UTC
I'm not sure why this was filed twice.

*** This bug has been marked as a duplicate of bug 658387 ***


Note You need to log in before you can comment on or make changes to this bug.