Bug 658387 - Patch to allow mbkernel and mbargs to be read from /etc/sysconfig/kernel
Patch to allow mbkernel and mbargs to be read from /etc/sysconfig/kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
Unspecified Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
RejectedBlocker
:
: 658386 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 03:39 EST by W. Michael Petullo
Modified: 2011-09-30 15:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: grubby-8.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Read HYPERVISOR and HYPERVISOR_ARGS from /etc/sysconfig/kernel and set mbkernel and mbargs (708 bytes, patch)
2010-11-30 03:39 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description W. Michael Petullo 2010-11-30 03:39:02 EST
Description of problem:
New-kernel-pkg has support for mbkernel and mbargs. However, there is no way to set these variables other than by using command line options. This does not support a single kernel which boots both on bare metal and from within a hypervisor such as Xen (upcoming Xen kernels will have this capability). I have attached a patch that reads mbkernel and mbargs from /etc/sysconfig/kernel:HYPERVISOR and :HYPERVISOR_ARGS, respectively. The allows a single kernel package to be installed to boot with or without a hypervisor.

This is a requirement for the Xen Pvops Dom0 feature that will be proposed for Fedora 15 (http://fedoraproject.org/wiki/Features/XenPvopsDom0).

Version-Release number of selected component (if applicable):
Git d3ca5734c2ca2f3dce2591d06ed609b9bfee756a
Comment 1 W. Michael Petullo 2010-11-30 03:39:39 EST
Created attachment 463663 [details]
Read HYPERVISOR and HYPERVISOR_ARGS from /etc/sysconfig/kernel and set mbkernel and mbargs
Comment 2 W. Michael Petullo 2010-12-21 00:34:23 EST
*** Bug 658386 has been marked as a duplicate of this bug. ***
Comment 3 W. Michael Petullo 2010-12-21 00:38:14 EST
Adding as a Fedora 15 blocker because FESCO has accepted the Xen pvops Dom0 feature for Fedora 15. Please see https://fedoraproject.org/wiki/Features/XenPvopsDom0 for a description of this feature.
Comment 4 Adam Williamson 2011-04-15 14:57:26 EDT
Discussed at 2011-04-15 blocker review meeting. We note the feature in question was dropped. Regardless, standing policy is that bugs which 'break' accepted features do not automatically qualify as release blockers: such issues are to be handled through the feature process (i.e. drop the feature in question), not the release validation process. They only count as blockers if they meet the blocker criteria, regardless of the feature process. This does not appear to hit any release criteria.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Pasi Karkkainen 2011-07-13 11:10:24 EDT
Xen dom0 is accepted feature for Fedora 16, and Xen dom0 support is included in upstream Linux kernel. So this patch should be applied now!
Comment 6 Pasi Karkkainen 2011-07-24 06:45:14 EDT
Anyone?
Comment 7 Adam Williamson 2011-07-25 23:02:46 EDT
I'm guessing Lennart wouldn't be a fan =)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Pasi Karkkainen 2011-08-10 08:01:50 EDT
Ping? This patch is needed for F16 !
Comment 9 Itamar Reis Peixoto 2011-08-16 14:51:15 EDT
any news about this ?
Comment 10 Fedora Update System 2011-09-14 16:11:07 EDT
grubby-8.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grubby-8.2-1.fc16
Comment 11 W. Michael Petullo 2011-09-15 10:59:52 EDT
I tested this new package on Fedora 15 and it seems to work there. Setting HYPERVISOR in /etc/sysconfig/kernel has the appropriate affect in the grub.cfg that new-kernel-pkg/grubby produces. However, there is still an issue with the "module /initramfs-..." line. See bug #668063.

I have not yet tested with Fedora 16/GRUB 2.
Comment 12 Fedora Update System 2011-09-15 17:21:27 EDT
Package grubby-8.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grubby-8.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/grubby-8.2-1.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-09-30 15:42:19 EDT
grubby-8.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.