Bug 658391 - Data corruption: resume from hibernate (Lenovo T500) always ends up with EXT3 fs errors
Data corruption: resume from hibernate (Lenovo T500) always ends up with EXT3...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 03:50 EST by Yaniv Kaul
Modified: 2013-07-03 22:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 770443 (view as bug list)
Environment:
Last Closed: 2012-05-14 13:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2010-11-30 03:50:17 EST
Description of problem:
After I resume from hibernation, on my F14 laptop (upgraded from F13, upgraded from F12), I always end up with programs that do not work - which ends up with me forcing to reboot the laptop, only to find out it's due to FS consistency issues on the EXT3 LV.

Let me know what more details you need from me to diagnose this.

Version-Release number of selected component (if applicable):
2.6.35.6-48.fc14.x86_64

How reproducible:
Always, I think. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Smirnoff 2011-02-18 18:23:42 EST
Same thing on x200s.

EXT4-fs error (device dm-1): ext4_mb_generate_buddy: EXT4-fs: group 6: 7851 blocks in bitmap, 7822 in gd
JBD: Spotted dirty metadata buffer (dev = dm-1, blocknr = 0). There's a risk of filesystem corruption in case of system crash.
Comment 2 David Juran 2011-06-17 01:19:33 EDT
Since updating to kernel-2.6.35.13-92.fc14.x86_64 I consistently get file system corruption on my ext3 root file system after resuming from hibernation.
Comment 3 Josh Boyer 2012-03-28 14:01:55 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.