This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 770443 - Data corruption: resume from hibernate (Lenovo G470) always ends up with EXT4 fs errors
Data corruption: resume from hibernate (Lenovo G470) always ends up with EXT4...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-12-26 11:01 EST by Nicolas Corrarello
Modified: 2012-05-14 13:58 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 658391
Environment:
Last Closed: 2012-05-14 13:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Corrarello 2011-12-26 11:01:29 EST
+++ This bug was initially created as a clone of Bug #658391 +++

Description of problem:
After I resume from hibernation, on my F16 laptop, I always end up with programs that do not work - which ends up with me forcing to reboot the laptop, only to find out it's due to FS consistency issues on the EXT4 LV.

Let me know what more details you need from me to diagnose this.

Version-Release number of selected component (if applicable):
3.1.4-1.fc16.x86_64

How reproducible:
Always, I think. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from ark@eltex.net on 2011-02-18 18:23:42 EST ---

Same thing on x200s.

EXT4-fs error (device dm-1): ext4_mb_generate_buddy: EXT4-fs: group 6: 7851 blocks in bitmap, 7822 in gd
JBD: Spotted dirty metadata buffer (dev = dm-1, blocknr = 0). There's a risk of filesystem corruption in case of system crash.

--- Additional comment from djuran@redhat.com on 2011-06-17 01:19:33 EDT ---

Since updating to kernel-2.6.35.13-92.fc14.x86_64 I consistently get file system corruption on my ext3 root file system after resuming from hibernation.
Comment 1 Stanislaw Gruszka 2011-12-31 06:50:49 EST
Does the laptop have i915 graphics hardware? If so, can you check if booting with i915.modeset=0 kernel parameter workaround the problem.
Comment 2 Eric Sandeen 2012-01-04 18:12:39 EST
If you find yourself needing to reinstall anyway, testing other filesystems (maybe ext3, maybe xfs to be even further from ext4) might be interesting.

Turning off the hard drive write cache before hibernate might also be interesting, if possible.

(Is this bug cloned because you hit it on ext4 not ext3, I guess?  Still, testing ext3 or xfs on the same hardware might be interesting)
Comment 3 Dave Jones 2012-03-22 13:05:33 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:08:40 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 13:19:23 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Josh Boyer 2012-03-28 14:00:39 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.