Bug 65877 - Dell WS530 Fails Audio Cert with SBLive
Dell WS530 Fails Audio Cert with SBLive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 13:19 EDT by Rogelio Noriega
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 12:24:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rogelio Noriega 2002-06-03 13:19:02 EDT
Description of Problem:
During the recording test audio fails, system has a segmentation fault. 

/usr/bin/rec: line 205: 25833 Segmentation fault sox $volume $arch_defines 
$fopts $device $fopts2 "$filename" $effects

Begin Digital Audio Playback Test
Digital Audio Playback Test Complete
Begin Recording Test
/etc/init.d/rhr-audio: line 109: 25730 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
/etc/init.d/rhr-audio: line 109: 25743 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 11000 (set to 11025)
/etc/init.d/rhr-audio: line 109: 25756 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 11000 (set to 11025)
/etc/init.d/rhr-audio: line 109: 25769 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 22000 (set to 22050)
/etc/init.d/rhr-audio: line 109: 25782 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 22000 (set to 22050)
/etc/init.d/rhr-audio: line 109: 25795 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 44000 (set to 44100)
/etc/init.d/rhr-audio: line 109: 25808 Killed                  rec -d /dev/
$DEVICE -r $x`echo 000` -c $y $TESTFILENAME
sox: Unable to set audio speed to 44000 (set to 44100)
/usr/bin/rec: line 205: 25833 Segmentation fault      sox $volume 
$arch_defines $fopts $device $fopts2 "$filename" $effects
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Premature EOF on .wav input file
sox: Can't open input file '44_2-test.out.wav': No such file or directory
Recording Test Completed

System also fails Midi test same message as bug 65876 on-board audio i810. 
Midi files play fine using kmidi.    

Begin Midi Audio Playback Test
open /dev/sequencer: No such device
Error playing midi sound.
Midi Audio Playback Test Complete


Version-Release number of selected component (if applicable):


How Reproducible:100%


Steps to Reproduce:
1. Run RHR7.3 Cert suite on WS530 with SBLive audio card.
2. 
3. 

Actual Results:








Expected Results:
Pass without errors

Additional Information:
Comment 1 Arjan van de Ven 2002-06-04 03:11:14 EDT
Those segmentation faults aren't oopses I hope ?
Comment 2 Rogelio Noriega 2002-06-10 12:20:02 EDT
No here is the error from the Digital Audio Playback Test.

/usr/bin/rec: line 205: 25833 Segmentation fault      sox $volume 
$arch_defines $fopts $device $fopts2 "$filename" $effects
Comment 3 John A. Hull 2002-06-10 19:26:18 EDT
We can get this to work by editing the rhr-audio file. In the record section, 
if you remark out "(sleep 5; killall -w -9 rec sox) >/dev/null 1>/dev/null 
2>/dev/null", and then manually kill each record process (at each 
frequency/channel) with CTRL-C, the test will pass.
Comment 4 Rob Landry 2002-06-11 16:02:38 EDT
The EMU10K doesn't have hardware midi; kmidi is translating the midi files from
midi to digial output using TiMidity++.  rhr-midi requires /dev/sequencer to
exist to run properly (ie hardware midi support).  Because the EMU10K doesn't in
hardware support midi it is not required to be tested.  This doesn't solve the
digital audio portion though.

Would you like to run through this as if it were an rhr-interact script problem
or leave it as kernel driver problem?
Comment 5 John A. Hull 2002-06-11 16:19:16 EDT
Does the i810 audio not have hardware midi support either (bugzilla #65876)? We 
get the same error on both: /dev/sequencer device does not exist.
Comment 6 Rob Landry 2002-06-11 16:30:34 EDT
Not as far as I know; most PCI audio adapters use software to emulate MIDI but
don't actually support it in hardware.
Comment 7 Doug Ledford 2002-06-11 16:31:43 EDT
No, there is no hardware midi support on any i810 hardware variant.
Comment 8 Rob Landry 2002-06-11 16:32:29 EDT
Can I asume that you're not getting the segmentation faults with the i810 or
does that mirror as well?
Comment 9 John A. Hull 2002-06-11 16:34:51 EDT
The only i810 problem we have is the midi /dev/sequencer issue.
Comment 10 Rogelio Noriega 2002-06-12 10:56:15 EDT
One other issue with i810 the cert test records and plays back all the files, 
but still reports the test as failing see below is this a bug in the script?

sox: Sound card appears to only support 2 channels.  Overriding format
                                                             [FAILED]
Comment 11 Larry Troan 2002-09-10 17:18:47 EDT
Per Chris K, this is not a failure. The sound card only supports two channels
and the cert test writes this into the log.
Comment 12 John A. Hull 2002-09-11 13:06:34 EDT
This is a different issue from the two-channel problem. This failure is 
actually a seg fault.
Comment 13 Rob Landry 2002-09-23 11:12:56 EDT
Do we know if this fails (ie seg faults); if record is run by hand instead of
within the scripts?  Also; do we know if other record apps fail in a similar way?

The point here it to determine if it's a driver bug, a record bug or if
something has changed within bash that is causing the scripts to fail.
Comment 14 Larry Troan 2002-09-24 10:05:48 EDT
Chris says this is because audio is only 2 channels. Cert test writes this in
log.... This is not a failure but only a limitation of the hardware. 
----
This Bugzilla should be closed as limitation of this specific hardware... not an
error/failure.
Comment 15 John A. Hull 2002-09-24 10:08:07 EDT
A segmentation fault is a limitation of the hardware??
Comment 16 John A. Hull 2002-10-14 12:24:15 EDT
Closing. Does not occur with Milan.

Note You need to log in before you can comment on or make changes to this bug.