Bug 658938 - mysql server fails to start
Summary: mysql server fails to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 656633 671064 682583 686886 688438 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 16:46 UTC by Gerald Henriksen
Modified: 2013-07-03 03:34 UTC (History)
12 users (show)

Fixed In Version: rsyslog-5.7.9-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-30 05:34:54 UTC


Attachments (Terms of Use)

Description Gerald Henriksen 2010-12-01 16:46:59 UTC
Description of problem:

Attempts to start mysql server fails, /var/log/mysqld.log reports this:

101201 11:03:46 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
101201 11:03:47  InnoDB: Started; log sequence number 0 44233
101201 11:03:47 [ERROR] /usr/libexec/mysqld: Can't create/write to file '/var/run/mysqld/mysqld.pid' (Errcode: 2)
101201 11:03:47 [ERROR] Can't start server: can't create PID file: No such file or directory
101201 11:03:47 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended


Perhaps it is related to bug 656633

Comment 1 Tom Lane 2010-12-01 17:03:00 UTC
Is the /var/run/mysqld/ directory present at all?  If not, this is breakage ensuing from the move-/var/run-to-tmpfs change, which is still being debated in fedora-devel.  I think the consensus at the moment is that it shouldn't be individual packages' responsibility to deal with the fallout from that.

Comment 2 Gerald Henriksen 2010-12-01 22:18:10 UTC
That directory is missing.

For now I will downgrade systemd to avoid the issue until a way to deal with it is decided and implemented.

Comment 3 Tom Lane 2011-01-20 15:03:39 UTC
*** Bug 671064 has been marked as a duplicate of this bug. ***

Comment 4 Ian Pilcher 2011-02-10 03:00:59 UTC
I just ran into this.  From what I can tell, the "correct" fix is to add an
appropriate file to /etc/tmpfiles.d, so I created /etc/tmpfiles.d/mysqld.conf:

  d /var/run/mysqld/ 0755 mysql mysql -

Running rpm -qf on the files in /etc/tmpfiles.d indicates that most of them
are *not* owned by the systemd package.  Going by that, this file should be
added to the mysql-server package.

Comment 5 megder 2011-03-06 22:24:39 UTC
*** Bug 682583 has been marked as a duplicate of this bug. ***

Comment 6 Michał Piotrowski 2011-03-18 17:42:57 UTC
Same issue here. Would have been nice to have this fixed soon :)

Comment 7 Rahul Sundaram 2011-03-21 17:54:16 UTC
(In reply to comment #1)
>  I think the consensus at the moment is that it shouldn't be
> individual packages' responsibility to deal with the fallout from that.

I don't think there is any such consensus.  All the other packages have fixed it.  It is a simple fix.  Please do it.  Thanks.

Comment 8 Fedora Update System 2011-03-22 04:01:20 UTC
mysql-5.5.10-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mysql-5.5.10-1.fc15

Comment 9 Tom Lane 2011-03-22 04:05:09 UTC
*** Bug 686886 has been marked as a duplicate of this bug. ***

Comment 10 Tom Lane 2011-03-22 04:05:43 UTC
*** Bug 688438 has been marked as a duplicate of this bug. ***

Comment 11 Tom Lane 2011-03-22 04:06:10 UTC
*** Bug 656633 has been marked as a duplicate of this bug. ***

Comment 12 Michał Piotrowski 2011-03-22 06:25:44 UTC
I need to wait for a rebuild before I can test it

error: Failed dependencies:
        libmysqlclient.so.16()(64bit) is needed by (installed) perl-DBD-MySQL-4.018-2.fc15.x86_64
        libmysqlclient.so.16()(64bit) is needed by (installed) php-mysql-5.3.6-1.fc15.x86_64
        libmysqlclient.so.16()(64bit) is needed by (installed) sphinx-0.9.9-5.fc15.x86_64
        libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) perl-DBD-MySQL-4.018-2.fc15.x86_64
        libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) php-mysql-5.3.6-1.fc15.x86_64
        libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) sphinx-0.9.9-5.fc15.x86_64
        libmysqlclient.so.16(libmysqlclient_16.1)(64bit) is needed by (installed) php-mysql-5.3.6-1.fc15.x86_64

Comment 13 Fedora Update System 2011-03-24 19:37:15 UTC
rsyslog-5.7.9-2.fc15, ruby-mysql-2.8.2-3.fc15, ser-0.9.6-21.fc15, sphinx-0.9.9-6.fc15, sysbench-0.4.12-4.fc15, tcl-mysqltcl-3.05-11.fc15, ulogd-1.24-15.fc15, UpTools-8.5.4-12.fc15, voms-mysql-plugin-3.1.3.2-3.fc15, wgrib2-1.9.1-5.fc15, yap-6.2.0-3.fc15, zabbix-1.8.4-4.fc15, zarafa-6.40.6-2.fc15, amarok-2.4.0-4.fc15, apr-util-1.3.10-7.fc15, asterisk-1.8.3.2-2.fc15, bacula-5.0.3-9.fc15, bind-9.8.0-2.fc15, callweaver-1.2.1-8.fc15, cherokee-1.2.1-2.fc15, cyrus-sasl-2.1.23-16.fc15, dolphin-connector-1.1-3.fc15, dovecot-2.0.11-2.fc15, dspam-3.9.0-19.fc15, EMBOSS-6.3.1-10.fc15, exim-4.73-3.fc15, freeradius-2.1.10-5.fc15, gambas2-2.22.0-8.fc15, gammu-1.26.1-6.fc15, gdal-1.7.3-5.fc15, gmyth-0.7.1-14.fc15, gnokii-0.6.29-3.fc15, grass-6.4.0-3.fc15, gstreamer-plugins-bad-free-0.10.21-3.fc15, Io-language-20080330-6.fc15, jabberd-2.2.13-2.fc15, koffice-2.3.3-4.fc15, lcgdm-1.8.0.1-7.fc15, libdbi-drivers-0.8.3-8.fc15, libgda-4.2.4-3.fc15, libnss-mysql-1.5-15.fc15, libpreludedb-1.0.0-7.fc15, libzdb-2.8-2.fc15, lighttpd-1.4.26-4.fc15, lua-sql-2.2.0-2.fc15, mapserver-5.6.5-5.fc15, mediatomb-0.12.1-9.fc15, mod_auth_mysql-3.0.0-14.fc15, mydns-1.2.8.31-3.fc15, mysql++-3.1.0-7.fc15, mysql-5.5.10-2.fc15, mysql-connector-c++-1.1.0-0.7.bzr895.fc15, mysql-connector-odbc-5.1.8-3.fc15, MySQL-python-1.2.3-3.fc15, mysql-workbench-5.2.33b-1.fc15, nagios-plugins-1.4.15-4.fc15, ndoutils-1.4-0.10.b9.fc15, nekovm-1.8.1-4.fc15, ntop-3.4-0.5.pre3.fc15, nufw-2.4.3-4.fc15.1, openscada-0.7.0.2-3.fc15, openser-1.3.4-17.fc15, opensips-1.6.4-6.fc15, pam_mysql-0.7-0.11.rc1.fc15.2, pdns-2.9.22-13.fc15, perl-DBD-MySQL-4.018-5.fc15, php-5.3.6-2.fc15, poco-1.4.1p1-1.fc15.1, postfix-2.8.2-2.fc15, proftpd-1.3.4-0.4.rc1.fc15, qt3-3.3.8b-35.fc15, qt-4.7.2-4.fc15, redland-1.0.12-3.fc15, rekall-2.4.6-17.fc15, root-5.28.00b-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/amarok-2.4.0-4.fc15,apr-util-1.3.10-7.fc15,asterisk-1.8.3.2-2.fc15,bacula-5.0.3-9.fc15,bind-9.8.0-2.fc15,callweaver-1.2.1-8.fc15,cherokee-1.2.1-2.fc15,cyrus-sasl-2.1.23-16.fc15,dolphin-connector-1.1-3.fc15,dovecot-2.0.11-2.fc15,dspam-3.9.0-19.fc15,EMBOSS-6.3.1-10.fc15,exim-4.73-3.fc15,freeradius-2.1.10-5.fc15,gambas2-2.22.0-8.fc15,gammu-1.26.1-6.fc15,gdal-1.7.3-5.fc15,gmyth-0.7.1-14.fc15,gnokii-0.6.29-3.fc15,grass-6.4.0-3.fc15,gstreamer-plugins-bad-free-0.10.21-3.fc15,Io-language-20080330-6.fc15,jabberd-2.2.13-2.fc15,koffice-2.3.3-4.fc15,lcgdm-1.8.0.1-7.fc15,libdbi-drivers-0.8.3-8.fc15,libgda-4.2.4-3.fc15,libnss-mysql-1.5-15.fc15,libpreludedb-1.0.0-7.fc15,libzdb-2.8-2.fc15,lighttpd-1.4.26-4.fc15,lua-sql-2.2.0-2.fc15,mapserver-5.6.5-5.fc15,mediatomb-0.12.1-9.fc15,mod_auth_mysql-3.0.0-14.fc15,mydns-1.2.8.31-3.fc15,mysql++-3.1.0-7.fc15,mysql-5.5.10-2.fc15,mysql-connector-c++-1.1.0-0.7.bzr895.fc15,mysql-connector-odbc-5.1.8-3.fc15,MySQL-python-1.2.3-3.fc15,mysql-workbench-5.2.33b-1.fc15,nagios-plugins-1.4.15-4.fc15,ndoutils-1.4-0.10.b9.fc15,nekovm-1.8.1-4.fc15,ntop-3.4-0.5.pre3.fc15,nufw-2.4.3-4.fc15.1,openscada-0.7.0.2-3.fc15,openser-1.3.4-17.fc15,opensips-1.6.4-6.fc15,pam_mysql-0.7-0.11.rc1.fc15.2,pdns-2.9.22-13.fc15,perl-DBD-MySQL-4.018-5.fc15,php-5.3.6-2.fc15,poco-1.4.1p1-1.fc15.1,postfix-2.8.2-2.fc15,proftpd-1.3.4-0.4.rc1.fc15,qt3-3.3.8b-35.fc15,qt-4.7.2-4.fc15,redland-1.0.12-3.fc15,rekall-2.4.6-17.fc15,root-5.28.00b-2.fc15,rsyslog-5.7.9-2.fc15,ruby-mysql-2.8.2-3.fc15,ser-0.9.6-21.fc15,sphinx-0.9.9-6.fc15,sysbench-0.4.12-4.fc15,tcl-mysqltcl-3.05-11.fc15,ulogd-1.24-15.fc15,UpTools-8.5.4-12.fc15,voms-mysql-plugin-3.1.3.2-3.fc15,wgrib2-1.9.1-5.fc15,yap-6.2.0-3.fc15,zabbix-1.8.4-4.fc15,zarafa-6.40.6-2.fc15

Comment 14 Fedora Update System 2011-03-30 05:34:48 UTC
rsyslog-5.7.9-2.fc15, ruby-mysql-2.8.2-3.fc15, ser-0.9.6-21.fc15, sphinx-0.9.9-6.fc15, sysbench-0.4.12-4.fc15, tcl-mysqltcl-3.05-11.fc15, ulogd-1.24-15.fc15, UpTools-8.5.4-12.fc15, voms-mysql-plugin-3.1.3.2-3.fc15, wgrib2-1.9.1-5.fc15, yap-6.2.0-3.fc15, zabbix-1.8.4-4.fc15, zarafa-6.40.6-2.fc15, amarok-2.4.0-4.fc15, apr-util-1.3.10-7.fc15, asterisk-1.8.3.2-2.fc15, bacula-5.0.3-9.fc15, bind-9.8.0-2.fc15, callweaver-1.2.1-8.fc15, cherokee-1.2.1-2.fc15, cyrus-sasl-2.1.23-16.fc15, dolphin-connector-1.1-3.fc15, dovecot-2.0.11-2.fc15, dspam-3.9.0-19.fc15, EMBOSS-6.3.1-10.fc15, exim-4.73-3.fc15, freeradius-2.1.10-5.fc15, gambas2-2.22.0-8.fc15, gammu-1.26.1-6.fc15, gdal-1.7.3-5.fc15, gmyth-0.7.1-14.fc15, gnokii-0.6.29-3.fc15, grass-6.4.0-3.fc15, gstreamer-plugins-bad-free-0.10.21-3.fc15, Io-language-20080330-6.fc15, jabberd-2.2.13-2.fc15, koffice-2.3.3-4.fc15, lcgdm-1.8.0.1-7.fc15, libdbi-drivers-0.8.3-8.fc15, libgda-4.2.4-3.fc15, libnss-mysql-1.5-15.fc15, libpreludedb-1.0.0-7.fc15, libzdb-2.8-2.fc15, lighttpd-1.4.26-4.fc15, lua-sql-2.2.0-2.fc15, mapserver-5.6.5-5.fc15, mediatomb-0.12.1-9.fc15, mod_auth_mysql-3.0.0-14.fc15, mydns-1.2.8.31-3.fc15, mysql++-3.1.0-7.fc15, mysql-5.5.10-2.fc15, mysql-connector-c++-1.1.0-0.7.bzr895.fc15, mysql-connector-odbc-5.1.8-3.fc15, MySQL-python-1.2.3-3.fc15, mysql-workbench-5.2.33b-1.fc15, nagios-plugins-1.4.15-4.fc15, ndoutils-1.4-0.10.b9.fc15, nekovm-1.8.1-4.fc15, ntop-3.4-0.5.pre3.fc15, nufw-2.4.3-4.fc15.1, openscada-0.7.0.2-3.fc15, openser-1.3.4-17.fc15, opensips-1.6.4-6.fc15, pam_mysql-0.7-0.11.rc1.fc15.2, pdns-2.9.22-13.fc15, perl-DBD-MySQL-4.018-5.fc15, php-5.3.6-2.fc15, poco-1.4.1p1-1.fc15.1, postfix-2.8.2-2.fc15, proftpd-1.3.4-0.4.rc1.fc15, qt3-3.3.8b-35.fc15, qt-4.7.2-4.fc15, redland-1.0.12-3.fc15, rekall-2.4.6-17.fc15, root-5.28.00b-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.