Bug 659813 - The bugzilla RPM should not depend on the bugzilla-contrib RPM
Summary: The bugzilla RPM should not depend on the bugzilla-contrib RPM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bugzilla
Version: 14
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 680670 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-03 19:10 UTC by Frédéric Buclin
Modified: 2011-03-16 19:54 UTC (History)
4 users (show)

Fixed In Version: bugzilla-3.6.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 04:41:29 UTC


Attachments (Terms of Use)

Description Frédéric Buclin 2010-12-03 19:10:54 UTC
The dependency is set in the wrong order. bugzilla-contrib should depend on bugzilla, not the opposite. It's not that common to use tools in contrib/. Also, the current dependency means that Ruby is required to install Bugzilla, which is a non-sense as Bugzilla is a pure Perl application. manu, could you fix that, please?

Comment 1 Emmanuel Seyman 2010-12-05 11:16:15 UTC
(In reply to comment #0)
>
> The dependency is set in the wrong order.

It's set both ways, actually. The bugzilla package depends on bugzilla-contrib and bugzilla-contrib depends on bugzilla.

> Also, the current dependency means that Ruby is required to install Bugzilla,
> which is a non-sense as Bugzilla is a pure Perl application.

Well, Ruby and Python but the latter seems inescapable in the Fedora ecosystem.

> manu, could you fix that, please?

The problem stems fron the fact that running checksetup.pl creates contrib/.htaccess . If the contrib directory doesn't exist, checksetup.pl fails and we can't afford to have that happen.

The two solutions that I can think of are :

* patch Bugzilla/Install/Filesystem.pl to ignore contrib/ if it doesn't exist.
* ship the bugzilla rpm with an empty contrib directory, the contrib sub-package itself containing only the files.

Note that I'll have to check that the second solution doesn't violate packaging guidelines.

LpSolit, any opinion ?

Comment 2 Frédéric Buclin 2010-12-05 12:39:43 UTC
(In reply to comment #1)
> Well, Ruby and Python but the latter seems inescapable in the Fedora ecosystem.

Python is maybe the de facto language in the Fedora world, but Bugzilla itself only requires Perl, and I don't know why another language is required.


> * patch Bugzilla/Install/Filesystem.pl to ignore contrib/ if it doesn't exist.
> * ship the bugzilla rpm with an empty contrib directory, the contrib
> sub-package itself containing only the files.

For the current problem, i.e. the Fedora RPM, you should include an empty contrib/ directory, so that you don't need to hack the code. But more globally, as this problem also exists for other Linux distros, you should file a bug upstream asking either checksetup.pl to first create contrib/ if it doesn't exists, or ignore contrib/.htaccess. The latter solution makes more sense as there is no need to configure an empty directory. On the other hand, already creating .htaccess would already protect contrib/ in case files are added to it by bugzilla-contrib later (so that you don't need to rerun checksetup.pl, unless bugzilla-contrib contains contrib/.htaccess itself). I will let mkanat decide what's best.

Comment 3 Max Kanat-Alexander 2010-12-05 18:26:29 UTC
The main package should ship a contrib/ with just recode.pl in it.

Comment 4 Emmanuel Seyman 2011-02-27 12:42:58 UTC
*** Bug 680670 has been marked as a duplicate of this bug. ***

Comment 5 Christopher Aillon 2011-02-27 18:33:00 UTC
Note: bug 680670 contains a proposed patch for this as attachment 481192 [details]

Comment 6 Fedora Update System 2011-03-08 09:34:05 UTC
bugzilla-3.6.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bugzilla-3.6.4-2.fc14

Comment 7 Fedora Update System 2011-03-08 09:34:41 UTC
bugzilla-3.4.10-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bugzilla-3.4.10-2.fc13

Comment 8 Fedora Update System 2011-03-08 09:35:08 UTC
bugzilla-3.6.4-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bugzilla-3.6.4-5.fc15

Comment 9 Emmanuel Seyman 2011-03-08 09:42:08 UTC
(In reply to comment #3)
>
> The main package should ship a contrib/ with just recode.pl in it.

Done.

Comment 10 Fedora Update System 2011-03-13 04:41:14 UTC
bugzilla-3.6.4-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-16 19:51:45 UTC
bugzilla-3.4.10-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-16 19:54:01 UTC
bugzilla-3.6.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.