Bug 680670 - Bugzilla should not Require ruby
Summary: Bugzilla should not Require ruby
Keywords:
Status: CLOSED DUPLICATE of bug 659813
Alias: None
Product: Fedora
Classification: Fedora
Component: bugzilla
Version: 13
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-26 20:52 UTC by Christopher Aillon
Modified: 2011-02-27 12:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-27 12:42:58 UTC


Attachments (Terms of Use)
Patch against git master (1.90 KB, patch)
2011-02-26 20:57 UTC, Christopher Aillon
no flags Details | Diff

Description Christopher Aillon 2011-02-26 20:52:48 UTC
Description of problem:
I was updating a server for a client to new bugzilla earlier and noticed it installed ruby.  I was forced to abort the update because they do not want to install ruby on the server.

The ruby dep comes as a result of bug 610198, which added a requirement on the -contrib package which contains a single ruby file.

Bug 610198 should have been solved by having the main bugzilla package own an _empty_ contrib/ directory, since the existence of the directory is expected to be part of the main install, but the contrib scripts are not.

Comment 1 Christopher Aillon 2011-02-26 20:57:25 UTC
Created attachment 481192 [details]
Patch against git master

can be applied with "git am 0001-The-main-package-should-own-contrib.patch"

Comment 2 Emmanuel Seyman 2011-02-27 12:42:58 UTC

*** This bug has been marked as a duplicate of bug 659813 ***


Note You need to log in before you can comment on or make changes to this bug.