Bug 660376 - [abrt] fontforge-20100501-4.fc14: CVLayer: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
Summary: [abrt] fontforge-20100501-4.fc14: CVLayer: Process /usr/bin/fontforge was kil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontforge
Version: 14
Hardware: i686
OS: Other
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2bc6764eb164538422b190c153b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 17:36 UTC by Pablo Rodríguez
Modified: 2011-04-05 21:43 UTC (History)
3 users (show)

Fixed In Version: fontforge-20110222-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-01 18:27:27 UTC


Attachments (Terms of Use)
File: backtrace (23.40 KB, text/plain)
2010-12-06 17:36 UTC, Pablo Rodríguez
no flags Details
backtrace from new build (1.57 KB, text/plain)
2011-02-26 16:29 UTC, Pablo Rodríguez
no flags Details

Description Pablo Rodríguez 2010-12-06 17:36:33 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: fontforge theano
component: fontforge
crash_function: CVLayer
executable: /usr/bin/fontforge
kernel: 2.6.35.9-64.fc14.i686
package: fontforge-20100501-4.fc14
rating: 4
reason: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1291655432
uid: 500

How to reproduce
-----
Open any font with fontforge.

Open a glyph, select all nodes with ctrl+a and press any of the arrow keys.

fontforge crashes and it shouldn't.

Comment 1 Pablo Rodríguez 2010-12-06 17:36:36 UTC
Created attachment 465027 [details]
File: backtrace

Comment 2 Kevin Fenzi 2010-12-06 18:45:05 UTC
I'll run this by upstream. Thanks for the bug report.

Comment 3 Pablo Rodríguez 2011-02-22 19:17:16 UTC
Kevin, it seems that a new version has been released today.

I wonder whether this fixes the issue.

Just in case it helps.

Comment 4 Kevin Fenzi 2011-02-22 21:19:12 UTC
Sure, worth trying. You still on f14? 

Can you try this build: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2858514

and see if it fixes the issue?

Comment 5 Pablo Rodríguez 2011-02-23 15:15:35 UTC
I'm afraid it wasn't fixed yet.

Thanks for the build.

Comment 6 Paul Flo Williams 2011-02-23 21:08:04 UTC
I can't reproduce this crash with the instructions given, so it looks like it isn't just any font and any glyph.

First of all, could you please try it with the simple font I attached to bug 631172:

https://bugzilla.redhat.com/attachment.cgi?id=480000

If this crashes for you, please let me know which glyph you picked and which arrow key you pressed.

If this doesn't crash for you, please let me know if you can reproduce this problem with any of the fonts that are already packaged for Fedora.

Comment 7 Pablo Rodríguez 2011-02-23 21:44:23 UTC
(In reply to comment #6)
> I can't reproduce this crash with the instructions given, so it looks like it
> isn't just any font and any glyph.
> 
> First of all, could you please try it with the simple font I attached to bug
> 631172:
> 
> https://bugzilla.redhat.com/attachment.cgi?id=480000

It crashes: exclamation mark and right.

Comment 8 Paul Flo Williams 2011-02-23 22:07:15 UTC
OK, thanks for the update.

I'm using fontforge-20100501-7.fc14.x86-64 (still in updates-testing). I see you're on i686, and I'm hoping that's not the crucial difference.

I open Domino.sfd from the attachment, double click on exclamation mark, Ctrl+A to select all points and press right arrow.

I see all points of the glyph move right. Any other direction is fine too.

My next move will be to update my laptop to F14 i686 and try to reproduce there.

Comment 9 Pablo Rodríguez 2011-02-25 07:07:49 UTC
(In reply to comment #4)
> Sure, worth trying. You still on f14? 
> 
> Can you try this build: 
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2858514
> 
> and see if it fixes the issue?

Here is the reply that George Williams gave to my bug report (on the fontforge-devel mailing list): http://sourceforge.net/mailarchive/message.php?msg_id=27113987.

It seems that there might be something wrong with the source version.

Thanks for your help,


Pablo

Comment 10 Pablo Rodríguez 2011-02-26 16:29:08 UTC
Created attachment 481162 [details]
backtrace from new build

Comment 11 Paul Flo Williams 2011-03-01 14:08:15 UTC
I've now tracked this down to an error that still exists in current upstream, so I've supplied a patch.

http://sourceforge.net/mailarchive/message.php?msg_id=27133628

Now waiting on confirmation upstream before applying the patch here.

Comment 12 Paul Flo Williams 2011-03-01 16:01:21 UTC
Pablo, can you try this build

https://koji.fedoraproject.org/koji/taskinfo?taskID=2876284

and see if it fixes the issue? It works for me.

Comment 13 Pablo Rodríguez 2011-03-04 17:59:14 UTC
(In reply to comment #12)
> Pablo, can you try this build
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=2876284
> 
> and see if it fixes the issue? It works for me.

It works for me too.

Many thanks for your help,

Pablo

Comment 14 Fedora Update System 2011-03-18 22:50:34 UTC
fontforge-20100501-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fontforge-20100501-8.fc14

Comment 15 Fedora Update System 2011-03-18 23:19:24 UTC
fontforge-20100501-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fontforge-20100501-8.fc15

Comment 16 Pablo Rodríguez 2011-03-20 12:17:07 UTC
Wouldn't it be better to patch the latest version and include this in Fedora 15?

Comment 17 Kevin Fenzi 2011-03-20 16:17:37 UTC
Well, for 15 it's possible, but in general we don't like to update fontforge in stable releases. It's used to build many fonts, and if there was a regression it would cause lots of problems for fonts updates. 

We can see if fonts folks are ok with updating 15 though, since it's not yet released.

Comment 18 Nicolas Mailhot 2011-03-21 08:56:15 UTC
There is still time to update 15 but someone needs to organize a mass rebuild to make sure the new version works with existing fonts (and notify package maintainers so they don't get offended someone else touches their package)

Comment 19 Fedora Update System 2011-03-31 17:23:05 UTC
fontforge-20110222-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fontforge-20110222-3.fc15

Comment 20 Fedora Update System 2011-03-31 19:44:20 UTC
Package fontforge-20110222-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontforge-20110222-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fontforge-20110222-3.fc15
then log in and leave karma (feedback).

Comment 21 Fedora Update System 2011-04-01 18:27:23 UTC
fontforge-20100501-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2011-04-05 21:43:48 UTC
fontforge-20110222-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.