Bug 660394 - Brightness Up/Down key not working on iMac 7,1
Brightness Up/Down key not working on iMac 7,1
Status: CLOSED DUPLICATE of bug 649084
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-06 13:03 EST by Raffaele Candeliere
Modified: 2011-01-20 11:12 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-18 15:25:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raffaele Candeliere 2010-12-06 13:03:46 EST
Description of problem:
Well, i'm not sure if it's a KDE issue or a kernel issue since i've the same problem with Gnome. 
The Mon Up/Down keys of the alu keyboard (iMac 7,1) don't work. No popup window appearing, no change in brightness level! 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Log into Gnome
2. Push the Brightness-Up or -Down button on the keyboard
3.
  
Actual results:
Nothing happens

Expected results:
Brightness should change


Additional info:
It was working with previous release of fedora (13)
Comment 1 Sergey 2011-01-13 04:29:59 EST
Can you change brightness in any other way? For example using commands:
* KDE:
solid-powermanagement brightness set [value]
* KDE PowerDevil + dbus:
qdbus org.kde.powerdevil /modules/powerdevil org.kde.PowerDevil.setBrightness 99
* xbacklight (`yum install xbacklight`)
xbacklight -set [value]
* manual write to /sys/class/backlight/
cat /sys/class/backlight/*/max_brightness
echo [value] > /sys/class/backlight/*/brightness
Comment 2 Raffaele Candeliere 2011-01-15 14:36:19 EST
Well, i suspect it's a problem with the X Server Keyboard bindings because the problems appears also in Gnome. Xev, actually, display the keyboard event as "BrightnessUp/Down" but nothing happens. (By the way, I don't know if monitor brightness is managed by X server at all). 
I have also tried the commands as per your suggestion: both solid-powermanagement and qdbus work. The manual write doesn't because no element exist under /sys/class/backlight/ (the command fails with the message: "file not found")
Comment 3 Lukáš Tinkl 2011-01-17 08:10:51 EST
It looks like Qt doesn't recognize your keys; does manually changing the brightness via the slider work for you? (in the battery applet)

And, please attach the exact output from xev
Comment 4 Rex Dieter 2011-01-18 15:25:32 EST

*** This bug has been marked as a duplicate of bug 649084 ***
Comment 5 Raffaele Candeliere 2011-01-20 11:12:07 EST
Ok. I don't know if it may help since the bug has been closed as duplicate, but by any chance here's the Xev output:

FocusOut event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 35, synthetic NO, window 0x0,
    keys:  40  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   1   0   0   

KeyRelease event, serial 35, synthetic NO, window 0x8000001,
    root 0x10b, subw 0x0, time 3906715, (394,130), root:(400,155),
    state 0x0, keycode 232 (keysym 0x1008ff03, XF86MonBrightnessDown), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 35, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   2   0   0   

KeyRelease event, serial 35, synthetic NO, window 0x8000001,
    root 0x10b, subw 0x0, time 3907451, (394,130), root:(400,155),
    state 0x0, keycode 233 (keysym 0x1008ff02, XF86MonBrightnessUp), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

P.S. Cannot try with the slider in the battery applet. The iMac is a desktop pc.

Note You need to log in before you can comment on or make changes to this bug.