Bug 649084 - Brightness soft keys on Macbook Pro doesn't works with KDE 4.5.2
Brightness soft keys on Macbook Pro doesn't works with KDE 4.5.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 660394 (view as bug list)
Depends On: 539961
Blocks: kde-4.5
  Show dependency treegraph
 
Reported: 2010-11-02 18:00 EDT by Jochen Schmitt
Modified: 2011-01-27 15:57 EST (History)
14 users (show)

See Also:
Fixed In Version: kdebase-workspace-4.5.5-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-27 15:57:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of upstream patch to solve brightness issue in KDE 4.5.5 (636 bytes, patch)
2011-01-18 14:11 EST, Jochen Schmitt
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 246521 None None None Never

  None (edit)
Description Jochen Schmitt 2010-11-02 18:00:45 EDT
Description of problem:

When I start Fedora 14 on my Macbook Pro the brightness of the display will be reduced during the startup phase of KDE-4.5.2 and I cant increase or decrease the brightness with the softkeys on the keyboard.

This issue doesn't occurs on GNOME !!!

Version-Release number of selected component (if applicable):

KDE-4.5.2

How reproducible:

Start KDE-4.5.2 on Fedora 13 or Fedora 14
  
Actual results:
Brightness will be reduced can can not been modified


Expected results:
Brightness should not been reduced. Brightness should be modified by using the softkeys on the keyboard.

Additional info:
This happens on the late 2009 15.4" Apple MacBook Pro. 

The issue doesn't occurs on KDE releases previous as 4.5 and on GNOME
Comment 1 Kevin Kofler 2010-11-02 20:31:35 EDT
> The issue doesn't occurs on KDE releases previous as 4.5

=> adding to the 4.5 tracker
Comment 2 Marius Andreiana 2010-11-12 14:48:19 EST
dupe of #539961 ?
Comment 3 Rex Dieter 2010-11-12 15:05:04 EST
heh, almost certainly (kde uses hal to do the heavy lifting).  Not sure if we should depend on it, or dup it... (let's just mark the dep for now).
Comment 4 Raffaele Candeliere 2010-12-06 12:31:19 EST
Same problem on alu iMac 20'' but with a difference: it doesn't work in Gnome either!
Comment 5 Jochen Schmitt 2010-12-26 10:02:35 EST
I think the issue is that the kind of how the backlight brighness is controlled on a Mac is depends on the modell you have.

Differnent modells of the Macaintosh has different controller and so different ways how to control the backlight brightness on it. So I will suggest the usage of the sysfs interface to controll of the brighness oI f the backlight.

After you have determinate the right path the kind of control should be simular on all Macaintosh modells.

For more details I want to reference to the sysfs_backlight.c file from the pommed project.
Comment 6 Sergey 2011-01-13 04:33:00 EST
Is this related to http://bugs.kde.org/show_bug.cgi?id=246521 ?

You can check that by trying to change brightness with commands:

solid-powermanagement brightness set [value]

If the command works, it's probably the same bug.
Comment 7 Jochen Schmitt 2011-01-18 12:36:08 EST
The command at comment #6 works fine for me and the but is not fixed on KDE 4.5.5.
Comment 8 Rex Dieter 2011-01-18 12:49:15 EST
I could perhaps whip up a quick-n-dirty scratch build including the upstream patch,
http://websvn.kde.org/?revision=1214119&view=revision
Comment 9 Jochen Schmitt 2011-01-18 14:11:58 EST
Created attachment 474131 [details]
Backport of upstream patch to solve brightness issue in KDE 4.5.5

this patch should fix the brightness issue in kDE 4.5.5. On my system (MacBook Pro late 2009) it's works fine.
Comment 10 Rex Dieter 2011-01-18 15:25:32 EST
*** Bug 660394 has been marked as a duplicate of this bug. ***
Comment 11 Rex Dieter 2011-01-18 16:23:30 EST
Try this out,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2729918
Comment 12 Fedora Update System 2011-01-18 16:25:05 EST
kdebase-workspace-4.5.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdebase-workspace-4.5.5-2.fc14
Comment 13 Marius Andreiana 2011-01-19 00:39:41 EST
How about Gnome? Brightness keys display the brightness value going up/down, but there is no actual change in screen brightness. (MBP 6.2)
Comment 14 Kevin Kofler 2011-01-19 01:40:42 EST
If GNOME is broken the same way, please file a different bug against GNOME, it's apparently not the same code which is faulty.
Comment 15 Fedora Update System 2011-01-19 16:12:05 EST
kdebase-workspace-4.5.5-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-workspace'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kdebase-workspace-4.5.5-2.fc14
Comment 16 Raffaele Candeliere 2011-01-24 10:21:01 EST
Yes, the problem is still there. I updated to kde-workspace 4.5.5-2 but still nothing happens when brightness buttons are hit on the keybord.

If it helps, this is my Xev output for the keys:

FocusOut event, serial 32, synthetic NO, window 0x8000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 32, synthetic NO, window 0x8000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 32, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   1   0   0   

KeyRelease event, serial 32, synthetic NO, window 0x8000001,
    root 0x10b, subw 0x0, time 488450, (401,327), root:(407,352),
    state 0x0, keycode 232 (keysym 0x1008ff03, XF86MonBrightnessDown), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 35, synthetic NO, window 0x8000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 35, synthetic NO, window 0x0,
    keys:  11  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   2   0   0   

KeyRelease event, serial 35, synthetic NO, window 0x8000001,
    root 0x10b, subw 0x0, time 489674, (401,327), root:(407,352),
    state 0x0, keycode 233 (keysym 0x1008ff02, XF86MonBrightnessUp), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 17 Fedora Update System 2011-01-27 15:57:15 EST
kdebase-workspace-4.5.5-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.