This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 660563 - resume from suspend, keyboard input no longer works
resume from suspend, keyboard input no longer works
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 660168 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 00:38 EST by Christopher Aillon
Modified: 2015-01-14 18:26 EST (History)
11 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.91.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-13 22:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot after resume (142.91 KB, image/png)
2010-12-07 00:38 EST, Christopher Aillon
no flags Details

  None (edit)
Description Christopher Aillon 2010-12-07 00:38:48 EST
Created attachment 465165 [details]
Screenshot after resume

Resume from suspend in gnome-shell, there is a sort of a weird window in the top left of the screen.  When this happens, I am able to use the mouse, however no keyboard input is accepted.

I have no problems at all in metacity, so guessing a shell bug.

gnome-shell-2.91.3-2.fc15.x86_64
mutter-2.91.3-2.fc15.x86_64
clutter-1.5.8-2.fc15.x86_64
xorg-x11-server-Xorg-1.9.99.1-1.20101201.fc15.x86_64
xorg-x11-drv-intel-2.13.901-5.fc15.x86_64
libdrm-2.4.23-0.2.20101123.fc15.x86_64
Comment 1 Christopher Aillon 2010-12-07 18:43:41 EST
Further data point, I get the same behavior using mutter standalone, so moving to mutter.
Comment 2 Peter Robinson 2010-12-07 20:05:55 EST
I'm actually seeing this as well on rawhide but it appears to be the screen saver. I can move the mouse around but get no keyboard until I realised if I put my password in and hit enter it works. Can you confirm if that's the case?
Comment 3 Christopher Aillon 2010-12-08 14:54:53 EST
Sadly, yes, entering my password and hitting enter gets that box to go away, and the desktop accepts input again.
Comment 4 Christopher Aillon 2010-12-08 14:58:21 EST
So, looking further, this seems to be due to the recent gtk3 version bump.  gnome-screensaver was attempted to be rebuilt for it, but the build failed:

http://koji.fedoraproject.org/koji/buildinfo?buildID=207570
Comment 5 Christopher Aillon 2010-12-08 15:04:39 EST
Looks like there's an upstream commit to fix this

http://git.gnome.org/browse/gnome-screensaver/commit/?id=a3388633c5f55b08df4f3af48b0dc2f0ef06d143
Comment 6 Peter Robinson 2010-12-08 17:54:24 EST
Also note this is also an issues with old style gnome 2 interface on rawhide.
Comment 7 Christopher Aillon 2010-12-09 01:07:56 EST
*** Bug 660168 has been marked as a duplicate of this bug. ***
Comment 8 Horst H. von Brand 2010-12-10 09:03:43 EST
My problem (660168) is fixed now (gnome-screensaver-2.91.2-2.fc15.x86_64).
Comment 9 Peter Robinson 2010-12-12 16:43:39 EST
(In reply to comment #8)
> My problem (660168) is fixed now (gnome-screensaver-2.91.2-2.fc15.x86_64).

It doesn't fix it for me.
Comment 10 Andrew Rechenberg 2010-12-28 10:16:10 EST
I opened Bug 664732 with this same issue.  I haven't noticed the window in the top left corner of the screen, however this issue only occurs for me after the screensaver being engaged for a long time (some time period > 2 hours).

I'll try the updated gnome-screensaver package but I won't know anything until tomorrow morning when I come in and my workstation will either work or not.
Comment 11 Andrew Rechenberg 2010-12-28 10:25:08 EST
Looks like I can't resolve this as I would have to replace most of my gnome packages on F14.  I'll try to apply the patch listed in comment #5 to the F14 SRPM and see if I can get it working.

A backport to the F14 package would be welcomed.
Comment 12 Andrew Rechenberg 2010-12-28 10:51:49 EST
Check that.  Looks like rawhide is using way different gnome libraries so I can't add that fix to the F14 packages.  So my Bug 664732 must be different
Comment 13 Peter Robinson 2011-01-23 10:38:06 EST
this looks fixed for me in rawhide (Andrew - F-14 is a different bug).
Comment 14 Peter Robinson 2011-03-13 22:39:57 EDT
Closing this as its fixed in F-15/rawhide

Note You need to log in before you can comment on or make changes to this bug.