Bug 660782 - FTBFS java-gnome-4.0.16-3.fc14
FTBFS java-gnome-4.0.16-3.fc14
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-gnome (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Boström
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 12:56 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-11 14:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (498.05 KB, text/plain)
2010-12-07 12:56 EST, FTBFS
no flags Details
build.log (681.43 KB, text/plain)
2010-12-07 12:56 EST, FTBFS
no flags Details
mock.log (883 bytes, text/plain)
2010-12-07 12:56 EST, FTBFS
no flags Details
root.log (725.69 KB, text/plain)
2010-12-07 12:57 EST, FTBFS
no flags Details
build.log (578.41 KB, text/plain)
2010-12-07 12:57 EST, FTBFS
no flags Details
mock.log (891 bytes, text/plain)
2010-12-07 12:57 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 12:56:51 EST
java-gnome-4.0.16-3.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 12:56:55 EST
Created attachment 465539 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 12:56:57 EST
Created attachment 465540 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 12:56:58 EST
Created attachment 465541 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 12:57:00 EST
Created attachment 465542 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 12:57:02 EST
Created attachment 465543 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 12:57:03 EST
Created attachment 465544 [details]
mock.log


mock.log for x86_64
Comment 7 Alexander Boström 2010-12-07 14:14:51 EST
Mentioned upstream:
http://article.gmane.org/gmane.comp.gnome.bindings.java.devel/1562

Short version: Not compatible with the new libnotify 0.7.0. Code and build system changes are needed and it also means a new Java-side API.
Comment 8 Hicham HAOUARI 2010-12-21 18:43:33 EST
I think the fix is fairly trivial, let me know if you need some help.
Comment 9 Mat Booth 2011-03-31 04:06:24 EDT
A Gnome 3 compatible version will be released soon:

http://article.gmane.org/gmane.comp.gnome.bindings.java.devel/1602
Comment 10 Fedora Update System 2011-04-02 17:17:58 EDT
java-gnome-4.0.19-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/java-gnome-4.0.19-1.fc15
Comment 11 Alexander Boström 2011-04-02 17:42:12 EDT
(In reply to comment #8)
> I think the fix is fairly trivial, let me know if you need some help.

Is is, but I wanted it to go through upstream since it means a change in the API on the Java side. I've built an update now that backports these API changes from upstream's 4.1 (GNOME 3) branch. This will likely also appear in the next 4.0 release.

(In reply to comment #9)
> A Gnome 3 compatible version will be released soon:

I would prefer to update to this directly and keep the API break in the new JAR filename (gtk-4.1.jar) but unfortunately the 4.1 branch is not usable yet.
Comment 12 Fedora Update System 2011-04-02 19:47:07 EDT
java-gnome-4.0.19-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/java-gnome-4.0.19-2.fc15
Comment 13 Fedora Update System 2011-04-02 23:57:00 EDT
Package java-gnome-4.0.19-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing java-gnome-4.0.19-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/java-gnome-4.0.19-1.fc15
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2011-04-03 04:05:53 EDT
java-gnome-4.0.19-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/java-gnome-4.0.19-3.fc15
Comment 15 Fedora Update System 2011-05-09 23:23:01 EDT
java-gnome-4.0.19-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Alexander Boström 2011-05-11 14:00:50 EDT
This particular problem has been fixed with a patch (though I'd like to go to 4.1 instead), but there's a new FTBFS in bug 703828.

Note You need to log in before you can comment on or make changes to this bug.