Bug 703828 - FTBFS with java-1.6.0-openjdk >= 1.6.0.0-55.1.10.fc15
Summary: FTBFS with java-1.6.0-openjdk >= 1.6.0.0-55.1.10.fc15
Status: CLOSED DUPLICATE of bug 715804
Alias: None
Product: Fedora
Classification: Fedora
Component: java-gnome   
(Show other bugs)
Version: 15
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Boström
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 719118
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-11 11:12 UTC by Dan Horák
Modified: 2011-07-05 20:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-05 20:37:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Horák 2011-05-11 11:12:56 UTC
java-gnome fails to build with java-1.6.0-openjdk >= 1.6.0.0-55.1.10.fc15 with a strange errors when running javadoc. It was originally discovered in Fedora 15  on s390x but can be reproduced with a rebuild in mock on x86_64. For the actual error messages please see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=380106

Comment 1 Alexander Boström 2011-05-11 18:10:54 UTC
Yeah, I'm aware, and it does build with to an older openjdk, but I need to narrow it down a bit before I can blame the compiler.

javadoc normally reads both the .java files it's given as arguments and also various .class files that are referenced from the source code, but here javadoc reads the .class files and interprets them as source code, it seems.

Comment 2 Dan Horák 2011-05-15 19:07:45 UTC
Thanks for the info. I've built the s390(x) package with the same openjdk as was used on x86, so it's not an urgent issue now.

Comment 3 Alexander Boström 2011-07-05 20:37:30 UTC

*** This bug has been marked as a duplicate of bug 715804 ***


Note You need to log in before you can comment on or make changes to this bug.