This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 661029 - FTBFS xxdiff-3.2-12.fc14
FTBFS xxdiff-3.2-12.fc14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: 0xFFFF (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Russell Cattelan
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F15FTBFS
  Show dependency treegraph
 
Reported: 2010-12-07 13:45 EST by FTBFS
Modified: 2011-06-16 15:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-24 14:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (14.92 KB, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details
build.log (671 bytes, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details
mock.log (764 bytes, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details
root.log (18.98 KB, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details
build.log (680 bytes, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details
mock.log (848 bytes, text/plain)
2010-12-07 13:45 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-12-07 13:45:13 EST
xxdiff-3.2-12.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:45:17 EST
Created attachment 466894 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:45:18 EST
Created attachment 466895 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:45:19 EST
Created attachment 466896 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:45:21 EST
Created attachment 466897 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:45:22 EST
Created attachment 466898 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:45:23 EST
Created attachment 466899 [details]
mock.log


mock.log for x86_64
Comment 7 Russell Cattelan 2010-12-10 10:51:47 EST
It appears that the qt-devel package has changed
to qt3-devel.

--- a/xxdiff.spec
+++ b/xxdiff.spec
@@ -9,7 +9,7 @@ URL:            http://furius.ca/xxdiff/
 # We remove the screenshots directory since the images in there can not be redistributed without permission.
 Source0:       xxdiff-%{version}-noscreenshots.tar.bz2
 BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: qt-devel < 1:4.0, bison, flex
+BuildRequires: qt3-devel < 1:4.0, bison, flex
 
 Patch0:                %{name}-fix-cstdlib_h.patch
Comment 8 Ralf Corsepius 2010-12-14 11:57:42 EST
(In reply to comment #7)
> It appears that the qt-devel package has changed
> to qt3-devel.
Yes, ...

> +BuildRequires: qt3-devel < 1:4.0, bison, flex

Except that BR: qt3-devel instead of BR: qt3-devel < 1:4.0 (qt3-devel is supposed to be < 4.0) would suffice, this seems correct to me.

Any particular reason for not applying this patch to the package? 
AFAIS, you're this package's Fedora maintainer.
Comment 9 Russell Cattelan 2011-01-24 14:00:20 EST
Fixed with commit
61c88a8a9278db7b90755bca7d6ee0e92d8bfc39ESC

Note You need to log in before you can comment on or make changes to this bug.