Bug 661673 - No updates in system overview
Summary: No updates in system overview
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space13
TreeView+ depends on / blocked
 
Reported: 2010-12-09 10:59 UTC by David Hrbáč
Modified: 2011-01-28 13:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-28 13:43:59 UTC


Attachments (Terms of Use)

Description David Hrbáč 2010-12-09 10:59:16 UTC
Description of problem:
We are using spacewalk to update machines. As of time being I can see that all machines are up-to-date within system overview. When I run yum check-update on any box I can see:
[root@sso-ha1 ~]# yum check-update
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
 * addons: ftp.fi.muni.cz
 * base: ftp.fi.muni.cz
 * extras: ftp.fi.muni.cz
 * hrb-stable: fs11.vsb.cz
 * updates: ftp.fi.muni.cz

tzdata.i386          2010l-1.el5          centos5-updates-i386

Centos5-updates-i386 is spacewalk provided channel.

Version-Release number of selected component (if applicable):
jabberd-2.2.11-1.el5
jabberpy-0.5-0.17.el5
osad-5.9.38-1.el5
osa-dispatcher-5.9.38-1.el5
spacewalk-setup-1.1.14-1.el5
spacewalk-setup-jabberd-1.2.2-1.el5

 
Actual results:
System overview shows no updates.

Expected results:
System overview has to show the updates.

Comment 1 David Hrbáč 2010-12-09 13:24:05 UTC
Repos are synced:
[root@spacewalk ~]# /usr/bin/spacewalk-rsync
/usr/bin/spacewalk-repo-sync --channel centos5-base-i386 --url http://merlin.fit.vutbr.cz/mirrors/centos/5/os/i386/ --type yum
Repo http://merlin.fit.vutbr.cz/mirrors/centos/5/os/i386/ has 2599 packages.
No new packages to download.
Sync complete
/usr/bin/spacewalk-repo-sync --channel centos5-updates-i386 --url http://merlin.fit.vutbr.cz/mirrors/centos/5/updates/i386/ --type yum
Repo http://merlin.fit.vutbr.cz/mirrors/centos/5/updates/i386/ has 828 packages.
No new packages to download.
Sync complete
/usr/bin/spacewalk-repo-sync --channel centos5-base-x86_64 --url http://merlin.fit.vutbr.cz/mirrors/centos/5/os/x86_64/ --type yum
Repo http://merlin.fit.vutbr.cz/mirrors/centos/5/os/x86_64/ has 3434 packages.
No new packages to download.
Sync complete
/usr/bin/spacewalk-repo-sync --channel centos5-updates-x86_64 --url http://merlin.fit.vutbr.cz/mirrors/centos/5/updates/x86_64/ --type yum
Repo http://merlin.fit.vutbr.cz/mirrors/centos/5/updates/x86_64/ has 1076 packages.
No new packages to download.
Sync complete
/usr/bin/spacewalk-repo-sync --channel hrb-i386 --url http://repository.vsb.cz/hrb33/el5/hrb/stable/i386/ --type yum
Repo http://repository.vsb.cz/hrb33/el5/hrb/stable/i386/ has 502 packages.
No new packages to download.
Sync complete
/usr/bin/spacewalk-repo-sync --channel hrb-x86_64 --url http://repository.vsb.cz/hrb33/el5/hrb/stable/x86_64/ --type yum
Repo http://repository.vsb.cz/hrb33/el5/hrb/stable/x86_64/ has 502 packages.
No new packages to download.

Comment 2 Michael Mráka 2010-12-09 14:05:30 UTC
It looks like this is a dup of bug 585965 which has been fixed in Spacewalk 1.2.

Is the issue still present in Spacewalk 1.2?

Comment 3 David Hrbáč 2010-12-10 13:42:32 UTC
Well, we have just upgraded to 1.2. I can see now updates on a few machines. Machines stoped communicating over jabber.

Osa-dispatcher is now again full of:
2010/12/10 14:27:41 +02:00 25128 0.0.0.0: osad/osa_dispatcher.process_once('Not notifying jabber nodes',)

So we are stuck again with clients not picking the tasks up. I must say 6 weeks spacewalk evaluation is continuous debug process for us. We have reported blocking bugs and howto hacks. This issue can be resolved with deleting all osad enabled boxes from spacewalk, regenerating osad-auth.conf and re-registering boxes. I don't want to do it every time I have to deal with spacewalk server...

Comment 4 Michael Mráka 2010-12-10 15:49:58 UTC
So if I read it correctly the system overview issue is fixed.
Thanks for confirming it.

As for osad please open new bugzilla with your observations and reproducer or feel free to add your comments to another osad related bugzilla if exists.

Thanks,
Michael

Comment 5 David Hrbáč 2010-12-13 08:47:04 UTC
Thanks, update helped. Osad is broken for now. I will report.
Thanks,
David

Comment 6 David Hrbáč 2010-12-23 08:54:18 UTC
Well, we still have this issue. I can see, that one of out system "is missing one packages" within Systems overview. Details are: tzdata-2010l-1.el5.x86_64.

From console I can see:
[root@vmdatrec ~]# rpm -qa | grep tzdata
tzdata-2010l-1.el5
tzdata-2010e-1.el5

[root@vmdatrec ~]# yum check-update
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
 * addons: merlin.fit.vutbr.cz
 * base: merlin.fit.vutbr.cz
 * extras: merlin.fit.vutbr.cz
 * hrb-stable: webmel4.vsb.cz
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: merlin.fit.vutbr.cz
addons                                                                          htop.x86_64         0.9-1.el5.rf         rpmforge
[root@vmdatrec ~]#

Comment 7 Michael Mráka 2011-01-28 13:43:59 UTC
WebUI:
https://xen90/rhn/systems/details/packages/UpgradableList.do?sid=1000010000
Upgradable Packages 
The following packages on this system are out-of-date and may be upgraded.   
Latest Package	Installed Package	Related Errata
No packages.

Client:
[root@xen17 ~]# rpm -q tzdata
tzdata-2010o-1.el5.i386
tzdata-2010k-1.el5.i386
[root@xen17 ~]# yum list tzdata --showduplicates
Loaded plugins: rhnplugin
Installed Packages
tzdata.i386                            2010k-1.el5                       installed
tzdata.i386                            2010o-1.el5                       installed
Available Packages
tzdata.i386                            2010k-1.el5                       rhel5 
tzdata.i386                            2010l-1.el5                       rhel5 
[root@xen17 ~]# yum update
Loaded plugins: rhnplugin
Setting up Update Process
No Packages marked for Update


I can't see any issue. Moving back to closed.


Note You need to log in before you can comment on or make changes to this bug.