Bug 661803 - can't be rebuild in mock
Summary: can't be rebuild in mock
Keywords:
Status: CLOSED DUPLICATE of bug 621089
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Test-Memory-Cycle
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-09 17:03 UTC by Levente Farkas
Modified: 2010-12-09 17:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-09 17:33:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Levente Farkas 2010-12-09 17:03:35 UTC
can't be rebuild in mock because durint %check it need perl-CGI which is not BR-ed.

Can't locate CGI.pm in @INC (@INC contains: /builddir/build/BUILD/Test-Memory-Cycle-1.04/blib/lib /builddir/build/BUILD/Test-Memory-Cycle-1.04/blib/arch /usr
/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at t/good.t line 7.
BEGIN failed--compilation aborted at t/good.t line 7.
# Looks like your test exited with 2 before it could output anything.
t/good.t ...........
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/2 subtests
t/pod-coverage.t ... ok
t/pod.t ............ ok
Test Summary Report
-------------------
t/good.t         (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 2 tests but ran 0.
Files=9, Tests=37,  1 wallclock secs ( 0.04 usr  0.02 sys +  0.27 cusr  0.03 csys =  0.36 CPU)
Result: FAIL
Failed 1/9 test programs. 0/37 subtests failed.
make: *** [test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.6cSuwB (%check)
RPM build errors:
    Macro % has illegal name (%define)
    Macro % has illegal name (%define)
    Bad exit status from /var/tmp/rpm-tmp.6cSuwB (%check)

Comment 2 Petr Pisar 2010-12-09 17:33:31 UTC

*** This bug has been marked as a duplicate of bug 621089 ***


Note You need to log in before you can comment on or make changes to this bug.