Bug 662224 - mplayer brightness adjust doesn't work with nouveau in X
mplayer brightness adjust doesn't work with nouveau in X
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
x86_64 Unspecified
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 704966 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-10 17:14 EST by stan
Modified: 2011-05-16 18:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-19 17:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stan 2010-12-10 17:14:26 EST
Description of problem:  
When using mplayer or gmplayer in X, the 3 and 4 keys don't work to adjust brightness.  They worked fine using the nv driver in F12.  Gnome desktop.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-13.20101010git8c8f15c.fc14.src.rpm


How reproducible:
every time


Steps to Reproduce:
1.  Run mplayer on avi video from within X
2.  Try to lower or increase brightness using 3 and 4 respectively
3.
  
Actual results:
Nothing happens

Expected results:
brightness adjusts


Additional info:  This does work within a console, for example Ctrl-Alt-F6.  The video hardware is an nvidia mx400.  Not sure this is a problem with nouveau, but seems the most likely culprit.  I would just use nv, but for some reason it won't go above 1024x768, while nouveau will run 1280x1024.  Nouveau didn't work for my system in F12, so can't compare this problem there.
Comment 1 Ben Skeggs 2010-12-19 17:33:32 EST
Hey, thank you for the report.  Unfortunately, this isn't an issue which will be fixed in the F14 lifetime.  'nv' can support these controls since it allows the use of the video overlay hardware.  Since the addition of KMS/TTM to 'nouveau' it hasn't yet been possible to use this in a sane way.

Xv is currently implemented via the 2D engine blitter on your chipset, which is not flexible enough to allow control over the colourspace conversion process.  The only reasonable mid-term solution is for someone to sit down and see whether this card's 3D engine is able to do a better job, and if so, to write a textured video Xv implementation.
Comment 2 stan 2010-12-19 19:39:12 EST
Thank you for the fast answer.  I thought this would be some obscure issue that would be unknown.  Writing a textured video Xv implementation is probably beyond me at this point.  And for such an old card maybe doesn't make sense.  So now that you've explained clearly what is going on I can decide what to do. Thanks again.
Comment 3 Ben Skeggs 2011-05-16 18:46:08 EDT
*** Bug 704966 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.