Bug 704966 - nouveau driver does not support brightness/contrast setting on nVidia Corporation G96 [Quadro FX 380]
nouveau driver does not support brightness/contrast setting on nVidia Corpora...
Status: CLOSED DUPLICATE of bug 662224
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 04:05 EDT by Petr Pisar
Modified: 2011-05-16 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-16 18:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2011-05-16 04:05:21 EDT
# lspci -s 1:0.0 -nn
01:00.0 VGA compatible controller [0300]: nVidia Corporation G96 [Quadro FX 380] [10de:0658] (rev a1)

# rpm -qa |grep nouve
xorg-x11-drv-nouveau-0.0.16-14.20101010git8c8f15c.fc14.x86_64

$ xvinfo 
X-Video Extension version 2.2
screen #0
  Adaptor #0: "Nouveau GeForce 8/9 Textured Video"
    number of ports: 32
    port base: 63
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
      depth 24, visualID 0x22
    number of attributes: 2
      "XV_SET_DEFAULTS" (range 0 to 0)
              client settable attribute
      "XV_SYNC_TO_VBLANK" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 4096 x 4096
    Number of image formats: 4
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)

See, there is no XV_BRIGHTNESS or XV_CONTRAST attribute, thus no video player (or xattr tool) can set brightness or contrast on XVideo adaptor. I doubt it's unsupported by hardware. It seems to be unimplemented in nouveau driver. (I don't know whether it worked before or did not.)
Comment 1 Ben Skeggs 2011-05-16 18:46:08 EDT
This is supported in F15 now, but will likely not be backported to F14.

*** This bug has been marked as a duplicate of bug 662224 ***

Note You need to log in before you can comment on or make changes to this bug.