This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 66229 - unhandle exception occurred in redhat-config-network
unhandle exception occurred in redhat-config-network
Status: CLOSED DUPLICATE of bug 65185
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-06-06 11:57 EDT by Cheng S. Wang
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 07:31:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cheng S. Wang 2002-06-06 11:57:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
After upgrading to 7.3 from 7.2, IP Aliases do not work anymore, and
redhat-config-network generates the following exception:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 531, in on_deviceEditButton_clicked
    button = self.editDevice(device)
  File "/usr/sbin/neat", line 561, in editDevice
    cfg = ethernetConfigDialog(device)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernetconfig.py",
line 61, in __init__
    device)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/deviceconfig.py", line
71, in __init__
    self.hydrate()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernetconfig.py",
line 95, in hydrate
    sharedtcpip.hardware_hydrate (self.sharedtcpip_xml, self.device)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/sharedtcpip.py",
line 286, in hardware_hydrate
    hwlist = NCHardwareList.getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 353, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in load
    wvdial = ConfSMB('/etc/wvdial.conf')
  File "/usr/lib/rhs/python/ConfSMB.py", line 34, in __init__
    merge=0, create_if_missing=0)
  File "/usr/lib/rhs/python/Conf.py", line 180, in __init__
    self.read()
  File "/usr/lib/rhs/python/ConfSMB.py", line 36, in read
    Conf.read(self)
  File "/usr/lib/rhs/python/Conf.py", line 258, in read
    raise FileMissing, self.filename + ' does not exist.'
Conf.FileMissing: /etc/wvdial.conf does not exist.

Local variables in innermost frame:
self: <ConfSMB.ConfSMB instance at 854aba0>
file_exists: 0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to 7.3 from 7.2 with IP Aliases network settings.
2.Start redhat-config-network.
3. Click one of the Active device.
	

Actual Results:  Exception occurred.

Expected Results:  Able to configure the active network device to set ip aliases.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 531, in on_deviceEditButton_clicked
    button = self.editDevice(device)
  File "/usr/sbin/neat", line 561, in editDevice
    cfg = ethernetConfigDialog(device)
 File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernetconfig.py",
line 61, in __init__
    device)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/deviceconfig.py", line
71, in __init__
    self.hydrate()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernetconfig.py",
line 95, in hydrate
    sharedtcpip.hardware_hydrate (self.sharedtcpip_xml, self.device)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/sharedtcpip.py",
line 286, in hardware_hydrate
    hwlist = NCHardwareList.getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 353, in getHardwareList
    HWList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in load
    wvdial = ConfSMB('/etc/wvdial.conf')
  File "/usr/lib/rhs/python/ConfSMB.py", line 34, in __init__
    merge=0, create_if_missing=0)
  File "/usr/lib/rhs/python/Conf.py", line 180, in __init__
    self.read()
  File "/usr/lib/rhs/python/ConfSMB.py", line 36, in read
    Conf.read(self)
  File "/usr/lib/rhs/python/Conf.py", line 258, in read
    raise FileMissing, self.filename + ' does not exist.'
Conf.FileMissing: /etc/wvdial.conf does not exist.

Local variables in innermost frame:
self: <ConfSMB.ConfSMB instance at 854aba0>
file_exists: 0
Comment 1 marga 2002-06-19 14:46:13 EDT
 Hi! I have the same problem. Every time I worked with RH 7.3 , I need to 
config my Ethernet Card, but these changes in the network configuration cannot 
be apply. 
 
Comment 2 Harald Hoyer 2002-06-26 07:22:14 EDT
workaround:

# touch /etc/wvdial.conf
Comment 3 Harald Hoyer 2002-06-26 08:37:44 EDT

*** This bug has been marked as a duplicate of 65185 ***
Comment 4 Harald Hoyer 2002-10-23 05:57:46 EDT
first beta of erratum for 7.3/7.2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.