This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 662452 - spicec should have a -title option
spicec should have a -title option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 663569
  Show dependency treegraph
 
Reported: 2010-12-12 13:19 EST by Tom Horsley
Modified: 2011-02-22 13:47 EST (History)
4 users (show)

See Also:
Fixed In Version: spice-protocol-0.6.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 663569 (view as bug list)
Environment:
Last Closed: 2011-02-22 13:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to add --title option (1.01 KB, patch)
2010-12-13 20:19 EST, Tom Horsley
no flags Details | Diff
PATCH to set the wm_class (1.63 KB, patch)
2010-12-15 10:41 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Tom Horsley 2010-12-12 13:19:12 EST
Description of problem:

Every spicec window is named "SPICEc:0". This is not real useful if you
are working with multiple virtual machines and want to find the window
for a particular one. Please provide a way to set the window manager title
in the spice client.


Version-Release number of selected component (if applicable):
spice-client-0.6.3-4.fc14.x86_64
Comment 1 Tom Horsley 2010-12-13 20:19:04 EST
Created attachment 468521 [details]
patch to add --title option

Add a title option is pretty trivial. I'm enclosing the patch I just
created to do it.
Comment 2 Hans de Goede 2010-12-14 04:23:37 EST
Hi,

Thanks for using spice, for the bug reports and for the patch. I did a very similar patch myself yesterday, but did not get around to update this bug yet.

I'm also working on your other 2 bug reports.

Once I've fixes for all 3, and they are reviewed upstream I'll build an updated spice package as a Fedora update.

Regards,

Hans
Comment 3 Gerd Hoffmann 2010-12-14 04:38:30 EST
I think the problem should better be tackled in a different way.  The spice protocol should be extended so the spice client can get meta informations about the virtual machine (with the name being the most important one).

With vnc we have that:  If you start your virtual machine using 'qemu -name $something' then connect to it using vnc the vnc client will display the name automatically, there is no need to set it manually.
Comment 4 Tom Horsley 2010-12-14 05:26:49 EST
Yep, getting the name automatically would make a lot of sense, but the
--title option was a lot simpler to add :-).

I also noticed that the window manager class is not set by spicec. Having the
class be SPICEc all the time even if the title is changed could be handy
for window managers to simplify spice window recognition.
Comment 5 Gerd Hoffmann 2010-12-14 07:54:17 EST
FYI: There is a gtk-based client in development.  It is already usable although isn't complete yet.  It should be alot less annonying as gtk does sane window management for us.

http://gitorious.org/spice-gtk/spice-gtk
Comment 6 Hans de Goede 2010-12-15 06:28:00 EST
(In reply to comment #3)
> I think the problem should better be tackled in a different way.  The spice
> protocol should be extended so the spice client can get meta informations about
> the virtual machine (with the name being the most important one).
> 
> With vnc we have that:  If you start your virtual machine using 'qemu -name
> $something' then connect to it using vnc the vnc client will display the name
> automatically, there is no need to set it manually.

I agree in principal, but this is not how things currently work. If the client is launched from the cmdline, currently we are stuck with a fixed title. And if the client is started through the RHEV-M interface using the browser xpi and the controller interface.

Sinds we will likely need to support overriding the title to the controller interface, even if set through to the to-be-written protocol extension, for the
near future. It makes sense to also add a --title cmdline option because:
1) It is almost zero code as we need title overriding code anyways
2) It will still be useful when connecting to virtual machines which are running a version of the spice protocol which does not pass the title info (which will be around for a while yet)
Comment 7 Hans de Goede 2010-12-15 10:41:58 EST
Created attachment 468878 [details]
PATCH to set the wm_class

Here is a patch to set the wm_class in case you're interested.

This will go upstream after review.
Comment 8 Fedora Update System 2011-02-14 04:46:03 EST
spice-protocol-0.6.4-1.fc14,spice-0.6.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-protocol-0.6.4-1.fc14,spice-0.6.4-1.fc14
Comment 9 Fedora Update System 2011-02-14 15:30:22 EST
spice-protocol-0.6.4-1.fc14, spice-0.6.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice-protocol spice'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-protocol-0.6.4-1.fc14,spice-0.6.4-1.fc14
Comment 10 Fedora Update System 2011-02-22 13:47:04 EST
spice-protocol-0.6.4-1.fc14, spice-0.6.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.