This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 663569 - spicec should have a -title option
spicec should have a -title option
Status: CLOSED DUPLICATE of bug 671383
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.2
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
:
Depends On: 662452
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 03:46 EST by Lubos Kocman
Modified: 2011-06-15 10:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 662452
Environment:
Last Closed: 2011-02-27 07:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-12-16 03:46:23 EST
It would definetly be really nice to have this in RHEL6.X. It really makes management of windows much easier when you're not using RHEVM and got multiple spice sessions openned.

+++ This bug was initially created as a clone of Bug #662452 +++

Description of problem:

Every spicec window is named "SPICEc:0". This is not real useful if you
are working with multiple virtual machines and want to find the window
for a particular one. Please provide a way to set the window manager title
in the spice client.


Version-Release number of selected component (if applicable):
spice-client-0.6.3-4.fc14.x86_64

--- Additional comment from horsley1953@gmail.com on 2010-12-13 20:19:04 EST ---

Created attachment 468521 [details]
patch to add --title option

Add a title option is pretty trivial. I'm enclosing the patch I just
created to do it.

--- Additional comment from hdegoede@redhat.com on 2010-12-14 04:23:37 EST ---

Hi,

Thanks for using spice, for the bug reports and for the patch. I did a very similar patch myself yesterday, but did not get around to update this bug yet.

I'm also working on your other 2 bug reports.

Once I've fixes for all 3, and they are reviewed upstream I'll build an updated spice package as a Fedora update.

Regards,

Hans

--- Additional comment from kraxel@redhat.com on 2010-12-14 04:38:30 EST ---

I think the problem should better be tackled in a different way.  The spice protocol should be extended so the spice client can get meta informations about the virtual machine (with the name being the most important one).

With vnc we have that:  If you start your virtual machine using 'qemu -name $something' then connect to it using vnc the vnc client will display the name automatically, there is no need to set it manually.

--- Additional comment from horsley1953@gmail.com on 2010-12-14 05:26:49 EST ---

Yep, getting the name automatically would make a lot of sense, but the
--title option was a lot simpler to add :-).

I also noticed that the window manager class is not set by spicec. Having the
class be SPICEc all the time even if the title is changed could be handy
for window managers to simplify spice window recognition.

--- Additional comment from kraxel@redhat.com on 2010-12-14 07:54:17 EST ---

FYI: There is a gtk-based client in development.  It is already usable although isn't complete yet.  It should be alot less annonying as gtk does sane window management for us.

http://gitorious.org/spice-gtk/spice-gtk

--- Additional comment from hdegoede@redhat.com on 2010-12-15 06:28:00 EST ---

(In reply to comment #3)
> I think the problem should better be tackled in a different way.  The spice
> protocol should be extended so the spice client can get meta informations about
> the virtual machine (with the name being the most important one).
> 
> With vnc we have that:  If you start your virtual machine using 'qemu -name
> $something' then connect to it using vnc the vnc client will display the name
> automatically, there is no need to set it manually.

I agree in principal, but this is not how things currently work. If the client is launched from the cmdline, currently we are stuck with a fixed title. And if the client is started through the RHEV-M interface using the browser xpi and the controller interface.

Sinds we will likely need to support overriding the title to the controller interface, even if set through to the to-be-written protocol extension, for the
near future. It makes sense to also add a --title cmdline option because:
1) It is almost zero code as we need title overriding code anyways
2) It will still be useful when connecting to virtual machines which are running a version of the spice protocol which does not pass the title info (which will be around for a while yet)

--- Additional comment from hdegoede@redhat.com on 2010-12-15 10:41:58 EST ---

Created attachment 468878 [details]
PATCH to set the wm_class

Here is a patch to set the wm_class in case you're interested.

This will go upstream after review.
Comment 1 Hans de Goede 2010-12-16 14:29:18 EST
Note, we are going to rebase spice-client to 0.7.x / 0.8.x for 6.1 for smartcard support. The upstream 0.7.0 release (and later) includes the patch for adding the --title option.
Comment 2 Hans de Goede 2011-02-27 07:55:41 EST
As mentioned this is fixed by the rebase t0 0.7.x / 0.8.0, closing.

*** This bug has been marked as a duplicate of bug 671383 ***

Note You need to log in before you can comment on or make changes to this bug.