Bug 662732 - UPX bundles lzma library -- and incorrectly does so in a form that reaches into ../../SOURCES/lzma465.tar.bz2
UPX bundles lzma library -- and incorrectly does so in a form that reaches in...
Status: CLOSED DUPLICATE of bug 564522
Product: Fedora
Classification: Fedora
Component: upx (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On: 564522 596461
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2010-12-13 13:15 EST by R P Herrold
Modified: 2011-04-05 14:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 564522
Environment:
Last Closed: 2011-04-05 14:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2010-12-13 13:15:48 EST
UPX bundles lzma library -- and incorrectly does so in a form that reaches into ../../SOURCES/lzma465.tar.bz2

+++ This bug was initially created as a clone of Bug #564522 +++

Description of problem:
the lzma sdk is bundled in our upx package.  This is not allowed and must be stopped.  From the looks of https://bugzilla.redhat.com/show_bug.cgi?id=501636 this change is only to enable lzma compression so if worse comes to worse we can remove the support and still have a usable package.  It would be better to find a solution that lets us unbundle liblzma and still retain the functionality, though.
========================

new content:

but ALSO, it is using buildsystem relative paths to reach up into ../../SOURCES, rather than carrying a clean reference to SOURCE1

I don't quite understand how this can work except for strange co-incidences in a particular build system as to path names

This can be fixed directly, pending a resolution on #564522's issue

-- Russ herrold
Comment 1 Gwyn Ciesla 2011-04-05 14:00:55 EDT

*** This bug has been marked as a duplicate of bug 564522 ***

Note You need to log in before you can comment on or make changes to this bug.