Bug 662743 - RFE: Add a python26-jinja2 package to EPEL5
Summary: RFE: Add a python26-jinja2 package to EPEL5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-jinja2
Version: el5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 657790 662739 668591 675628
Blocks: 662750
TreeView+ depends on / blocked
 
Reported: 2010-12-13 19:10 UTC by Steve Traylen
Modified: 2016-09-20 02:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-03 09:29:16 UTC
Type: ---


Attachments (Terms of Use)
F15 spec file adapted for python26-jinja2 in EPEL5 (5.35 KB, text/plain)
2011-01-27 19:17 UTC, Steve Traylen
no flags Details

Description Steve Traylen 2010-12-13 19:10:18 UTC
Hi, 

I like to see python26-jinga2 package in EPEL5.

This is currently not possible due to missing dependencies but I'll try
to provide some patches once it it is unblocked.

Comment 1 Thomas Moschny 2011-01-13 11:58:50 UTC
Is there a consensus on whether we should create py26 subpackages from the main packages or have completely separate specfiles?

Comment 2 Steve Traylen 2011-01-13 12:25:23 UTC
Hi Thomas, 

Both  options are quite possible and it depends on a few factors:

http://fedoraproject.org/wiki/Packaging:Python#Common_SRPM_vs_split_SRPMs

A cursory look I see you have same version in EPEL5 and rawhide and your rawhide
already has a python3 variant.

As such if it were me adding a with_python26 option makes a lot of sense. I'm happy to provide
a patch once the markupsafe is in place.

Comment 3 Steve Traylen 2011-01-26 21:59:47 UTC
Hi Thomas,

> A cursory look I see you have same version in EPEL5 and rawhide and your
> rawhide
> already has a python3 variant.

I was mistaken here , I now see that EPEL5 is 2.2.1 where as devel is
2.5.5.

I am unsure of the significance here but I expect a new python26-jinga2
package probably make sense.

python26-markupsafe is now on its way to the testing repo.

Steve

Comment 4 Steve Traylen 2011-01-27 19:17:12 UTC
Created attachment 475667 [details]
F15 spec file adapted for python26-jinja2 in EPEL5

 
This is a python26-jinja2 .spec file suitable for EPEL5.

I am hoping you might like to submit it for review... Once you have checked it of course.

Steve.

Comment 5 Thomas Moschny 2011-01-28 16:04:48 UTC
(In reply to comment #4)
> This is a python26-jinja2 .spec file suitable for EPEL5.
> 
> I am hoping you might like to submit it for review... Once you have checked it
> of course.

Will do so, but I'm currently a busy, so not before end of next week.

Comment 6 Thomas Moschny 2011-03-03 09:29:16 UTC
python26-jinja2-2.5.5-4.el5 has been pushed to the Fedora EPEL 5 stable repository.


Note You need to log in before you can comment on or make changes to this bug.