Bug 662913 - v7: guest swapon fail in kvm virtualization job
Summary: v7: guest swapon fail in kvm virtualization job
Keywords:
Status: CLOSED DUPLICATE of bug 663901
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (tests)
Version: 1.2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 07:11 UTC by chen yuwen
Modified: 2011-01-06 07:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-06 07:35:21 UTC


Attachments (Terms of Use)
v7 virtualization job (1005 bytes, text/xml)
2010-12-14 07:11 UTC, chen yuwen
no flags Details
fv_memory testing log in v7 virtualization job (1.24 KB, application/octet-stream)
2010-12-14 07:13 UTC, chen yuwen
no flags Details
virsh console log of fv_memory testing (15.26 KB, application/octet-stream)
2010-12-14 07:14 UTC, chen yuwen
no flags Details
log of starting v7x86_64.img manually (12.92 KB, application/octet-stream)
2010-12-14 07:16 UTC, chen yuwen
no flags Details

Description chen yuwen 2010-12-14 07:11:35 UTC
Created attachment 468539 [details]
v7 virtualization job

Description of problem:
fv_tests fail in virtualization job, except fv_network:
"Error: memory run on guest Failed"

run "virsh console v7x86_64", error in guest as follow:
<output>
Running ./memory.py:
<output name="Limits" description="Get test parameters based on hardware">
System Memory: 498 MB
Free Memory: 397 MB
Swap Memory: 0 MB
<summary>PASS</summary>
</output>
<output name="Single-process" description="None">
Starting Threaded Memory Test
Error: this test requires non-zero swap memory.
<summary>FAIL</summary>
</output>
...finished running ./memory.py, exit code=1
</output>

run "/usr/libexec/qemu-kvm -hda /var/lib/libvirt/images/v7x86_64.img -nographic" to start the guest.
[root@dhcp-65-79 ~]# free
             total       used       free     shared    buffers     cached
Mem:        122948     112140      10808          0       5252      33824
-/+ buffers/cache:      73064      49884
Swap:            0          0          0
[root@dhcp-65-79 ~]# cat /etc/fstab 
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
[root@dhcp-65-79 ~]# swapon /dev/VolGroup00/LogVol01
Unable to find swap-space signature
swapon: /dev/VolGroup00/LogVol01: Invalid argument

At this point, run command:
[root@dhcp-65-79 ~]# mkswap /dev/VolGroup00/LogVol01
Setting up swapspace version 1, size = 1073737 kB
[root@dhcp-65-79 ~]# swapon /dev/VolGroup00/LogVol01

and then rerun all fv_tests, and all pass.

Version-Release number of selected component (if applicable):
RHEL5.6, RHEL6.0

How reproducible:
100%

Steps to Reproduce:
1. submit a v7 virtualization job
2.
3.
  
Actual results:
all FAIL except fv_network

Expected results:
all PASS

Additional info:
The swap failure won't happen if provisioning RHEL5.6 or RHEL6 manually.

Comment 1 chen yuwen 2010-12-14 07:13:25 UTC
Created attachment 468540 [details]
fv_memory testing log in v7 virtualization job

Comment 2 chen yuwen 2010-12-14 07:14:32 UTC
Created attachment 468541 [details]
virsh console log of fv_memory testing

Comment 3 chen yuwen 2010-12-14 07:16:40 UTC
Created attachment 468542 [details]
log of starting v7x86_64.img manually

Comment 4 chen yuwen 2010-12-15 07:48:06 UTC
A related bug on ia64: https://bugzilla.redhat.com/show_bug.cgi?id=649673

Comment 5 Rob Landry 2011-01-05 20:27:35 UTC
Is this something unique to and/or caused by beaker?  ..as of yet I'm not seeing the outcry from the vendors who use this everyday.

Comment 7 chen yuwen 2011-01-06 07:35:21 UTC

*** This bug has been marked as a duplicate of bug 663901 ***


Note You need to log in before you can comment on or make changes to this bug.