Bug 663124 - gpsd steals USB serial ports, cannot be removed
Summary: gpsd steals USB serial ports, cannot be removed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gpsd
Version: 14
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Douglas E. Warner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 752923 863630 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 19:21 UTC by H. Peter Anvin
Modified: 2012-10-08 11:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-26 15:57:55 UTC
Type: ---


Attachments (Terms of Use)

Description H. Peter Anvin 2010-12-14 19:21:54 UTC
Description of problem:

KDE in Fedora 14 depends on gpsd through the dependencies:

        libgps.so.19()(64bit) is needed by (installed) kdeedu-marble-libs-4.5.3-2.fc14.x86_64
        libgps.so.19()(64bit) is needed by (installed) kdebase-workspace-4.5.3-3.fc14.x86_64


Unfortunately, the gpsd RPM is configured to have udev invoke it on /dev/ttyUSB0 when that device is invoked, regardless of chkconfig setting.  This means USB serial ports are unusable! 


Version-Release number of selected component (if applicable):

gpsd-2.95-2.fc14.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install Fedora 14 with KDE
2. Try to use a USB serial port

  
Actual results:

- Serial port busy, unwanted output sent to serial port

Expected results:

- USB serial port usable

Suggested fix:

- Either separate libgps out from the gpsd RPM, or make it harmless unless explicitly configured.

Comment 1 Miroslav Lichvar 2010-12-14 19:31:01 UTC
Making a -libs subpackage sounds reasonable.

In the meantime add USBAUTO=no to /etc/sysconfig/gpsd.

Comment 2 Hans Ulrich Niedermann 2011-05-03 20:14:35 UTC
I just ran into the same thing with an FTDI FT232RL USB VID/PID 0403/6001 device. This device is mentioned in /etc/udev/rules.d/99-gpsd.rules as if it was a GPS device - but it is just a generic FTDI FT232RL chip!

Given that USB-to-RS232 adapters are used for many more devices than just a few GPS devices, I would say USBAUTO=no would be a good default value for gpsd unless gpsd's udev rules can somehow be fixed to distinguish between FTDI chip based GPS devices and generic FTDI chips attached to nothing at all or other device types.

Comment 3 Miroslav Lichvar 2011-07-26 15:57:55 UTC
gpsd-2.95-7.fc16 has a -libs subpackage. It also explicitly sets USBAUTO=true in the sysconfig file, so it's easier to see how it can be disabled.

Comment 4 Miroslav Lichvar 2011-11-11 12:08:28 UTC
*** Bug 752923 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Lichvar 2012-10-08 11:50:10 UTC
*** Bug 863630 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.