Bug 863630 - gpsd prevents FT232 serial ports from being used
gpsd prevents FT232 serial ports from being used
Status: CLOSED DUPLICATE of bug 663124
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 01:52 EDT by Alex G.
Modified: 2012-10-08 07:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 07:50:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex G. 2012-10-06 01:52:31 EDT
Description of problem:
Attempting to use a FT232 USB to serial converter does not work.

How reproducible:
Always

Steps to Reproduce:
1. log in with a user in the "dialout" group
2. connect an FT232 USB-to-serial converter
3. Attempt to open the serial port
  
Actual results:
$ picocom /dev/ttyUSB0 -b115200 
[..]
FATAL: cannot open /dev/ttyUSB0: Device or resource busy

Expected results:
Serial port works normally.

Additional info:
Trying to find why the resource is busy leads to gpsd
$ sudo lsof /dev/ttyUSB0
COMMAND   PID   USER   FD   TYPE DEVICE SIZE/OFF     NODE NAME
gpsd    28540 nobody    7u   CHR  188,0      0t0 17364030 /dev/ttyUSB0

Which leads to the culprit rule in /etc/udev/rules.d/99-gpsd.rules:
# FTDI 8U232AM / FT232 [linux module: ftdi_sio]
ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
Comment 1 Miroslav Lichvar 2012-10-08 07:50:10 EDT
This is a known issue, you can disable USBAUTO in /etc/sysconfig/gpsd or uninstall gpsd completely.

*** This bug has been marked as a duplicate of bug 663124 ***

Note You need to log in before you can comment on or make changes to this bug.