Bug 663818 - Windows printer name is corrupted when setting up a new printer etc.
Summary: Windows printer name is corrupted when setting up a new printer etc.
Keywords:
Status: CLOSED DUPLICATE of bug 669820
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 13
Hardware: Unspecified
OS: Linux
low
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-16 22:50 UTC by David Ford
Modified: 2011-01-18 10:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-18 10:53:45 UTC
Type: ---


Attachments (Terms of Use)

Description David Ford 2010-12-16 22:50:04 UTC
Description of problem:

The name windows allocates to the printer queue is corrupted with html characters when a new Windows printer is created.

In my case for example the Windows printer name was :-
HP Photosmart C4100 series (Copy 5)

system-config-printer rendered this as:-
HP20Photosmart20C410020series2028Copy20529

(As the "Device URI" box was only long enough to display the workgroup and part of the server name - it took me nearly all day to realise that "tree connect failed: NT_STATUS_BAD_NETWORK_NAME" and system-config-printer asking me to provide a user name and password - then a "resource not available" message really meant that the printer name was miss-spelled. Oh well - that's life!) 

Version-Release number of selected component (if applicable):

system-config-printer-1.2.5-6.fc13.i686
cups-1.4.4-11.fc13.i686

How reproducible:
Every time

Steps to Reproduce:
1.set up a windows printer
2.
3.
  
Actual results:
Windows printer name is filled with semi-html characters

Expected results:
Windows printer name should be the same as selected from those offered by the 'Browse' button

Additional info:

Comment 1 Horst H. von Brand 2011-01-17 14:52:37 UTC
I'm affected by bug 669820, which seems to be the same.

Workaround for me was to go to the CUPS page <http://localhost:631/> and create an entry for the printer there, not via Administration --> Printing.

Hope this helps.

Comment 2 Tim Waugh 2011-01-18 10:53:45 UTC

*** This bug has been marked as a duplicate of bug 669820 ***


Note You need to log in before you can comment on or make changes to this bug.