Bug 669820 - dnssd unable to resolve URI for HP network printer
Summary: dnssd unable to resolve URI for HP network printer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 663818 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-14 21:33 UTC by Horst H. von Brand
Modified: 2011-03-15 21:56 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.2.7-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-30 02:15:30 UTC


Attachments (Terms of Use)
Contets of /var/log/error.log for job 661 (failed) (14.55 KB, text/plain)
2011-01-14 21:33 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2011-01-14 21:33:38 UTC
Created attachment 473592 [details]
Contets of /var/log/error.log for job 661 (failed)

Description of problem:
Our printer broke, and was offline for a week or so. After it came back, I deleted the original configuration and created it anew, which worked fine. The printer shows disabled in System --> Administration --> Printing, enabling it there doesn't work (it shows up enabled a short time, doing anything disables it). Trying to print anything shows the printer as off-line.

Cups says it is 'Paused - "/usr/lib/cups/backend/dnssd failed"'. avahi-browse -a finds the printer just fine:

+   eth0 IPv4 HP LaserJet M1522nf MFP (284314)              Web Site             local
+   eth0 IPv4 HP LaserJet M1522nf MFP (284314)              PDL Printer          local
+   eth0 IPv4 HP LaserJet M1522nf MFP (284314)              UNIX Printer         local

"cupsenable dcsc" shows it briefly as "ready and printing" (lpq), and then again "not ready"

Version-Release number of selected component (if applicable):
cups-1.4.6-1.fc15.x86_64
cups-1.4.6-2.fc15.x86_64

How reproducible:
Always...

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2011-01-17 11:48:27 UTC
For some reason the device URI has lost some "%" characters.

Can you please run 'lpstat -s', showing the URIs of both the working queue and the non-working queue?  Thanks.

Comment 2 Horst H. von Brand 2011-01-17 12:48:54 UTC
There is only one remote queue, and that one doesn't work.

# lpstat -s
system default destination: dcsc
device for dcsc: dnssd://HP20LaserJet20M1522nf20MFP20284314._printer._tcp.local/

Comment 3 Horst H. von Brand 2011-01-17 12:51:32 UTC
(In reply to comment #1)
> For some reason the device URI has lost some "%" characters.
> 
> Can you please run 'lpstat -s', showing the URIs of both the working queue and
> the non-working queue?  Thanks.

Oops, now I understand. What worked fine was the discovery and adding of the printer (I had trouble with this before), printing on the printer never worked. The printer itself is fine, others here can print on it.

Comment 4 Tim Waugh 2011-01-17 13:05:54 UTC
OK, this looks similar to bug #663818 then.

Comment 5 Horst H. von Brand 2011-01-17 14:48:01 UTC
In a rare flash of creativity, I went to the CUPS page on localhost and (re)created the printer there. Lo and behold, the URI is fine now... some tweaks via Administration --> Printing (set as default, give it the right driver, ...) and now it shows as "ready and printing" after printing something. Printout turned out OK.

BTW, it lost % and (), the correct URI is dnssd://HP%20LaserJet%20M1522nf%20MFP%20(284314)._pdl-datastream._tcp.local/

Comment 6 Horst H. von Brand 2011-01-17 14:55:31 UTC
Packages here are:

cups-1.4.6-5.fc15.x86_64
system-config-printer-1.2.95-4.fc15.x86_64

Comment 7 Jiri Popelka 2011-01-18 10:41:48 UTC
(In reply to comment #5)
> BTW, it lost % and (), the correct URI is
> dnssd://HP%20LaserJet%20M1522nf%20MFP%20(284314)._pdl-datastream._tcp.local/

Whoops, I know what's going on here. Fixed upstream.
http://git.fedorahosted.org/git/?p=system-config-printer.git;a=commitdiff;h=3c9f99afd64e10ef119f13c45d62a1a75773dcc1

I will prepare testing package immediately.

Comment 8 Tim Waugh 2011-01-18 10:53:45 UTC
*** Bug 663818 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2011-01-18 11:22:49 UTC
system-config-printer-1.2.6-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-2.fc14

Comment 11 Fedora Update System 2011-01-18 11:26:14 UTC
system-config-printer-1.2.6-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-2.fc13

Comment 12 Jiri Popelka 2011-01-18 11:47:30 UTC
For system-config-printer-1.2.96-2.fc15 see
https://koji.fedoraproject.org/koji/buildinfo?buildID=214617

Comment 14 Horst H. von Brand 2011-01-18 12:58:53 UTC
(In reply to comment #12)
> For system-config-printer-1.2.96-2.fc15 see
> https://koji.fedoraproject.org/koji/buildinfo?buildID=214617

Just updated to it. It finds the printer (twice?), shows the correct URI, etc.

Comment 15 Horst H. von Brand 2011-01-18 13:00:52 UTC
BTW, for bug 663818 it seems to have recoded '(' and ')' as "%28" and "%29" and then stripped '%'

Comment 16 Tim Waugh 2011-01-18 13:53:53 UTC
Horst: what does 'lpstat -l -v' say?

Comment 17 Fedora Update System 2011-01-18 21:29:04 UTC
system-config-printer-1.2.6-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/system-config-printer-1.2.6-2.fc13

Comment 18 Horst H. von Brand 2011-01-20 12:53:33 UTC
(In reply to comment #16)
> Horst: what does 'lpstat -l -v' say?

system-config-printer-1.2.96-2.fc15.x86_64
cups-1.4.6-6.fc15.x86_64

]# lpstat -l -v
device for dcsc: dnssd://HP%20LaserJet%20M1522nf%20MFP%20(284314)._pdl-datastream._tcp.local/

Comment 19 Tim Waugh 2011-01-20 15:37:33 UTC
Thanks.

Comment 20 Horst H. von Brand 2011-01-21 16:20:38 UTC
Fixed for me, dunno about the other reporter...

Comment 21 Horst H. von Brand 2011-01-30 02:15:30 UTC
Seems there are no further comments. Closing.

Comment 22 Fedora Update System 2011-02-07 20:00:25 UTC
system-config-printer-1.2.6-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2011-03-15 21:55:45 UTC
system-config-printer-1.2.7-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.