Bug 6640 - You have no Linux partitions
You have no Linux partitions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
All Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-02 01:47 EST by borgia
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 11:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description borgia 1999-11-02 01:47:41 EST
Situation: homemade cd with all updates (including boot
disks) included (and indexes rebuilt with gendhdlist);
booting from cdrom.

Fdisk says:
[root@nausicaa /root]# fdisk
Using /dev/sda as default device!

The number of cylinders for this disk is set to 8715.
(blah blah)
Command (m for help): p
Disk /dev/sda: 64 heads, 32 sectors, 8715 cylinders
Units = cylinders of 2048 * 512 bytes
   Device Boot    Start       End    Blocks   Id
System
/dev/sda1   *         1       801    820208    6
FAT16
/dev/sda2           802      8715   8103936    f  Win95
Ext'd (LBA)
/dev/sda5           802      1002    205808   83
Linux
/dev/sda6          1003      6502   5631984    b  Win95
FAT32
/dev/sda7          6503      8003   1537008   83
Linux
/dev/sda8          8004      8504    513008   83
Linux
/dev/sda9          8505      8605    103408   83
Linux
/dev/sda10         8606      8715    112624   82  Linux
swap

The huge number of cylinders is due to the FirePort BIOS not
doing any kind of extended translation and can't be
changed.
/dev/sda5 is the root partition and is right below the BIOS
limit, in order to allow Lilo to boot the system
correctly.
/dev/sda7 is /usr
/dev/sda8 is /home
/dev/sda9 is /var

Now, the latest bootdisks were supposed to fix this, right?
Am I missing something, like what I'm doing is not possible
and I should boot from floppy only or something like that?
Please advise.
Comment 1 Jay Turner 1999-11-02 11:01:59 EST
This is a duplicate of bug #5511 and is a result of the Win95 extended
partitions which you have.  The Red Hat installer is not able to see
into these partitions and therefore is telling you that it cannot find
a linux installation.  Contrary to the errata site, this bug is not
actually fixed by the latest errata which was posted.  The only thing
that I can suggest is that for the duration of the upgrade, you change
the type "f" partitions which you have to type "5"  You can change it
back after the upgrade and things will work great from that point.  I
am closing this bug to prevent further clutter with bug #5511, so
please refer to that bug for further information about this issue.

Note You need to log in before you can comment on or make changes to this bug.