Bug 66419 - a2ps crashes when used as user, but prints fine as root
a2ps crashes when used as user, but prints fine as root
Status: CLOSED DUPLICATE of bug 40532
Product: Red Hat Linux
Classification: Retired
Component: a2ps (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-10 04:03 EDT by Romke Bontekoe
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 04:03:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Romke Bontekoe 2002-06-10 04:03:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
a2ps crashes when used as an ordinary user. however running it as
su or su - it prints fine. I am running 
a2ps-4.13b-15.i386.r on kernel 2.4.9-31smp.
One more detail, 
a2ps --version runs fine and gives the version number (as ordinary user), but 
anything else crashes.


 




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. >> a2ps packages
Segmentation fault (core dumped)

(Note "packages" is an ascii file with, as you probably guessed, all package names)

2. >> a2ps --version
GNU a2ps 4.13
Written by Akim Demaille, Miguel Santana.

Copyright (c) 1988-1993 Miguel Santana
Copyright (c) 1995-2000 Akim Demaille, Miguel Santana
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


3. as su or su - the command "a2ps packages" just prints the file
packages fine.

	

Actual Results:  see above

Expected Results:  file printed

Additional info:

see above
Comment 1 Tim Waugh 2002-06-10 06:11:01 EDT
This sounds just like bug #40532, which has been fixed in the package provided 
with Red Hat Linux 7.3. 

*** This bug has been marked as a duplicate of 40532 ***

Note You need to log in before you can comment on or make changes to this bug.