This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 664627 - mailq manpage does not display
mailq manpage does not display
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: postfix (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
: ManPageChange
Depends On:
Blocks: 749203
  Show dependency treegraph
 
Reported: 2010-12-20 20:40 EST by Billy Coutsis
Modified: 2013-01-08 02:27 EST (History)
5 users (show)

See Also:
Fixed In Version: postfix-2.3.3-5.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update the man pages for mailq, newaliases, sendmail and aliases didn't display, because they wasn't supported by alternatives. The support was added to alternatives and now the man pages can be displayed.
Story Points: ---
Clone Of:
: 749203 (view as bug list)
Environment:
Last Closed: 2013-01-08 02:27:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backported patch (742 bytes, patch)
2011-09-26 09:24 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Billy Coutsis 2010-12-20 20:40:20 EST
Description of problem:
Cannot display manpage for postfix's mailq(1) command.

Version-Release number of selected component (if applicable):
postfix-2.3.3-2.1.el5_2

How reproducible:
Always.

Steps to Reproduce:
1. yum install postfix && alternatives --set mta /usr/bin/sendmail.postfix && man mailq
2. Observe that "man mailq" fails (see below).

  
Actual results:
[root@mail ~]# man mailq
fopen: No such file or directory
Cannot open man page /usr/share/man/man1/sendmail.1.gz
No manual entry for mailq
[root@mail ~]#

Expected results:
[root@mail ~]# man mailq
(mailq manpage is displayed)

Additional info:
I think the "/usr/share/man/man1/mailq.postfix.1.gz" file is broken: it references "man1/sendmail.1", but the filesystem only has a "/usr/share/man/man8/sendmail.8.gz". Either that, or the sendmail manpage should be in category 1, not 8.
Comment 1 Billy Coutsis 2010-12-20 20:57:19 EST
This bug may be CentOS-specific. My bad.
Comment 2 Michael Stevens 2011-07-15 08:21:08 EDT
(In reply to comment #1)
> This bug may be CentOS-specific. My bad.

I'm also seeing this in "real" RHEL 5
Comment 3 RHEL Product and Program Management 2011-09-22 20:13:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 Loye Young 2011-09-23 06:43:39 EDT
The following is a work around. 

<code>
ln -s /usr/share/man/man1/sendmail.postfix.1.gz /usr/share/man/man1/sendmail.1.gz
</code>

A symlink could be distributed with an updated rpm.
Comment 5 Jaroslav Škarvada 2011-09-26 09:24:57 EDT
Created attachment 524904 [details]
Backported patch

There is same issue with newaliases. The backported patch should fix it all.
Comment 7 RHEL Product and Program Management 2012-04-02 06:21:53 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 11 Jaroslav Škarvada 2012-06-28 04:41:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update the man pages for mailq, newaliases, sendmail and aliases didn't display, because they wasn't supported by alternatives. The support was added to alternatives and now the man pages can be displayed.
Comment 14 errata-xmlrpc 2013-01-08 02:27:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0054.html

Note You need to log in before you can comment on or make changes to this bug.