Bug 664849 - uploading to the "UNO" board file with "avdude: Yikes! Invalid device signature."
Summary: uploading to the "UNO" board file with "avdude: Yikes! Invalid device signatu...
Keywords:
Status: CLOSED DUPLICATE of bug 663177
Alias: None
Product: Fedora
Classification: Fedora
Component: arduino
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Oliver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-21 20:44 UTC by Giovanni Bacci
Modified: 2010-12-21 22:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-21 22:43:01 UTC
Type: ---


Attachments (Terms of Use)
a boards.txt file working (8.96 KB, text/plain)
2010-12-21 20:46 UTC, Giovanni Bacci
no flags Details

Description Giovanni Bacci 2010-12-21 20:44:54 UTC
Description of problem:

  When I try to upload a program to the "UNO" board, the operation fails wit this message:
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

Version-Release number of selected component (if applicable):
arduino-core-0021-1.fc14.noarch


How reproducible:

just load a simple program, compile it and try to upload to the UNO board

Steps to Reproduce:
1. load/write a simple program
2. compile
3. upload
  
Actual results:
fail with this message:
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

Expected results:
the compiled program should be uploaded to the board

Additional info:
After some investigation, i've found the solution (from here:
https://bugs.launchpad.net/arduino/+bug/529444)
Just open
/usr/share/arduino/hardware/arduino/boards.txt
and modify
uno.upload.protocol=stk500
to:
uno.upload.protocol=arduino
Detailed explanation in the previous link

Comment 1 Giovanni Bacci 2010-12-21 20:46:47 UTC
Created attachment 470078 [details]
a boards.txt file working

Here's the modified /usr/share/arduino/hardware/arduino/boards.txt that does the trick

Comment 2 Peter Oliver 2010-12-21 22:43:01 UTC

*** This bug has been marked as a duplicate of bug 663177 ***


Note You need to log in before you can comment on or make changes to this bug.