Bug 663177 - Upload to Arduino Uno reports "Yikes, Invalid device signature"
Summary: Upload to Arduino Uno reports "Yikes, Invalid device signature"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arduino
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Oliver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 664849 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 21:39 UTC by mb0606
Modified: 2011-01-02 19:50 UTC (History)
2 users (show)

Fixed In Version: arduino-0021-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-30 20:21:38 UTC


Attachments (Terms of Use)

Description mb0606 2010-12-14 21:39:17 UTC
Description of problem:
When installing the arduino package (arduino-0021-1.fc14.noarch.rpm) the incorrect avrdude (in /usr/bin) and avrdude.conf (in /etc/avrdude) are installed.
The correct files (avrdude and avrdude.conf) are to be found on the arduino site.
Just erasing or renaming the avrdude files from the fedora package and replacing them with the files from the original arduino.tgz package will solve all problems.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rename/erase /etc/avrdude/avrdude.conf and /usr/bin/avrdude
2. unpack original arduino.tgz package
3. copy the avrdude.conf and avrdude bin file from the /hardware/tools/ directory in the arduino package
  
Actual results:
Communication, identification and recognition of Arduino boards does no longer produce error report ("Yikes, Invalid device signature")

Expected results:
Uploading to arduino board works as it should


Additional info:

Comment 1 Peter Oliver 2010-12-15 00:48:27 UTC
I assume from bug 650849 comment 7 that you experience this with the Arduino Uno boards.  I don't have an Uno to test against.  Could you replace the original avrdude and avrdude.conf, and try changing /usr/share/arduino/hardware/arduino/boards.txt so that it reads "uno.upload.protocol=arduino"?

Comment 2 mb0606 2010-12-16 21:04:11 UTC
As requested, I changed back to the original fedora avrdude.conf and avrdude binary included in the Fedora arduino package (arduino-0021-1.fc14.noarch.rpm)

Then I edited the /usr/share/arduino/hardware/arduino/boards.txt file  
to show  "uno.upload.protocol=arduino " instead of "uno.upload.protocol=stk500"

Plugged in the Arduino UNO board and now uploading worked right away (no error reports. Arduino GUI shows "done uploading".

Perfect ! It feels great to have helped solving a bug after so many years being able to use open and free software. I am glad I have been able to give some back. This tastes for more !!

Comment 3 Fedora Update System 2010-12-17 01:14:36 UTC
arduino-0021-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/arduino-0021-2.fc14

Comment 4 Fedora Update System 2010-12-17 01:14:43 UTC
arduino-0021-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/arduino-0021-2.fc13

Comment 5 Fedora Update System 2010-12-17 08:24:22 UTC
arduino-0021-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update arduino'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/arduino-0021-2.fc13

Comment 6 Peter Oliver 2010-12-21 22:43:01 UTC
*** Bug 664849 has been marked as a duplicate of this bug. ***

Comment 7 mb0606 2010-12-22 19:31:52 UTC
I have installed the arduino-0021-2 package for Fedora 14.
yum --enablerepo=updates-testing update arduino

Yum reported correctly I had edited the boards.txt file (delta does not match installed data).

Have connected my arduino Uno and uploading works righ away.

Seems to me the update package is OK.

Comment 8 Fedora Update System 2010-12-30 20:21:33 UTC
arduino-0021-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-01-02 19:50:08 UTC
arduino-0021-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.