Bug 66498 - missing package emacs-nox
missing package emacs-nox
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-11 10:02 EDT by Warren Jasper
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 10:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Jasper 2002-06-11 10:02:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-4 i686)

Description of problem:
When running mh, I like to select emacs as my editor.  However, when I'm
on a slow connection, I like to use the nox version (emacs -nw).  However,
in the .mh_profile file, 

Editor: emacs-nox

worked just fine until that was taken out.  I have not figured out a way to
pass an argument ie

Editor: emacs -nw  /* does not work */

How do I envoke emacs in the "no X" mode without passing it an argument, 
similar to /usr/bin/emacs-nox

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.in the file ~/.mh_profile add the line Editor: emacs-nox
2.comp   (compose a message)
3.emacs-nox is not there!
	

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-06-11 10:08:04 EDT
Emacs-nox isn't missing - as you've noted, you can run emacs with "-nw".

As for how you pass arguments through .mh_profile, I'm not sure, but this is a
bug report forum, not a support channel. I suggest you ask on some mailing lists
- e.g. valhalla-list or redhat-list.
Comment 2 Alex Yacoub 2002-06-27 12:17:14 EDT
I feel that the lack of a nox package is a bug, because the emacs package
depends on XFree86-libs.  For those of us who want emacs but don't want X, this
is a definite problem.

What prompted RedHat to deprecate the nox package?
Comment 3 Alex Yacoub 2002-06-27 12:18:53 EDT
Ignore my ignorant comment.  I posted it before reading bug 64832.
Comment 4 Jens Petersen 2004-01-23 12:14:23 EST
Fwiw emacs-nox is available again with emacs-21.3-9 soon
in FC devel.

Note You need to log in before you can comment on or make changes to this bug.