Bug 665060 - add support for the postlogin PAM stack to kdm
add support for the postlogin PAM stack to kdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 665059
Blocks: 486152 F16Target-kde
  Show dependency treegraph
 
Reported: 2010-12-22 10:46 EST by Paolo Bonzini
Modified: 2014-06-09 07:40 EDT (History)
16 users (show)

See Also:
Fixed In Version: 4.6-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 486152
Environment:
Last Closed: 2011-02-01 12:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to the upstream package (1.57 KB, patch)
2010-12-22 10:54 EST, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Paolo Bonzini 2010-12-22 10:46:02 EST
In order to use the automount feature of ecryptfs, for the ~/Private folder, some modifications to /etc/pam.d/system-auth are required.  In order to integrate pam_ecryptfs.so awareness into authconfig, we decided to create a new PAM stack.  This is because of the wide usage of "sufficient" modules for the primary authentication modules (pam_unix, pam_krb5, pam_sss, pam_ldap) in the configurations generated by authconfig.
Comment 1 Paolo Bonzini 2010-12-22 10:54:16 EST
Created attachment 470224 [details]
patch to the upstream package
Comment 2 Paolo Bonzini 2011-02-01 11:12:17 EST
Comment on attachment 470224 [details]
patch to the upstream package

Built http://koji.fedoraproject.org//koji/taskinfo?taskID=2754225 with this patch, please review and apply.
Comment 3 Rex Dieter 2011-02-01 12:55:54 EST
Thanks!

%changelog
* Tue Feb 01 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6-3
- add support for the postlogin PAM stack to kdm (#665060)

Note You need to log in before you can comment on or make changes to this bug.