Bug 665760 - missing lirc file in lirc-0.9.0-0.1.pre1.fc15.x86_64 for handling with systemd
Summary: missing lirc file in lirc-0.9.0-0.1.pre1.fc15.x86_64 for handling with systemd
Keywords:
Status: CLOSED DUPLICATE of bug 656613
Alias: None
Product: Fedora
Classification: Fedora
Component: lirc
Version: rawhide
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-26 18:02 UTC by Wolfgang Ulbrich
Modified: 2011-01-05 00:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-26 18:04:50 UTC
Type: ---


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2010-12-26 18:02:14 UTC
Description of problem:
lircd can't create /var/run/lirc/lirc.pid

Version-Release number of selected component (if applicable):
lirc-0.9.0-0.1.pre1.fc15.x86_64

How reproducible:
starting lirc_serial

Steps to Reproduce:
1.
2.
3.
  
Actual results:
/var/run/lirc/lirc.pid can't created because the folder /var/run/lirc/ doesn't exits

Expected results:
lird should create /var/run/lirc/lirc.pid

Additional info:
The problem is that systemd create /var/run as tmpfs. So after a restart the folder /var/run/lirc/ is missing.
I solved the problem as i create a /etc/tmpfiles.d/lirc.conf file.

lirc.conf:
d /var/run/lirc 0755 root root

With that file the systemd 'systemd-tmpfiles-setup.service' create a folder /var/run/lirc/ at startup. 
And lircd can create /var/run/lirc/lirc.pid.

Comment 1 Jarod Wilson 2010-12-26 18:04:50 UTC

*** This bug has been marked as a duplicate of bug 656613 ***

Comment 2 Wolfgang Ulbrich 2011-01-05 00:14:07 UTC
Thx for information.


Note You need to log in before you can comment on or make changes to this bug.