This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 656613 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
:
: 665760 706625 709557 (view as bug list)
Depends On:
Blocks: 827166
  Show dependency treegraph
 
Reported: 2010-11-23 18:32 EST by Lennart Poettering
Modified: 2012-05-31 15:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: lirc-0.9.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-29 19:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2010-11-23 18:32:48 EST
Your package lirc appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Jarod Wilson 2010-12-26 13:04:50 EST
*** Bug 665760 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2011-05-03 16:12:55 EDT
lirc-0.9.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lirc-0.9.0-3.fc15
Comment 3 Fedora Update System 2011-05-05 00:41:49 EDT
Package lirc-0.9.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lirc-0.9.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lirc-0.9.0-3.fc15
then log in and leave karma (feedback).
Comment 4 Jarod Wilson 2011-05-21 22:39:53 EDT
*** Bug 706625 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Lichvar 2011-05-28 07:43:44 EDT
The /var/run/lirc directory isn't created on package installation, only on reboot. It shouldn't be marked as %ghost.
Comment 6 Fedora Update System 2011-05-29 19:19:34 EDT
lirc-0.9.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Jarod Wilson 2011-05-31 23:16:34 EDT
*** Bug 709557 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.