Bug 66578 - TB NCHardwareList.:288:save KeyError: options
TB NCHardwareList.:288:save KeyError: options
Status: CLOSED DUPLICATE of bug 65073
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brock Organ
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-06-12 10:44 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 11:29:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-12 10:44:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; {World Online})

Description of problem:
I use gnome. I go to start here -> network configuration --> hardware --> add --
> ne1000,ne2000 compatible --> irq 3, io 0x300 . OK --> close --> error

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
	

Actual Results:  Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 458, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8538650>
hw: <netconfpkg.HardwareList.Hardware instance at 84fe9a0>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 85383a0>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84f6dd0>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 84fe9a0>]


Expected Results:  Going back to previous menu, with an extra item added 
(ne2000 card) 

Additional info:

I have also a problem with my isdn card. Maybe it has some thing to do with it.

The ne2000 compatible network card is an old card - not PCI. not plug and play. 
To use it on irq 3 and com2 i turned off in the bios. It works under Win98.
Comment 1 Larry Sevilla 2002-10-02 04:07:04 EDT
OS: RedHat 7.3 Valhalla

Network Configuration

Hardware-Add-Ethernet

Adapter: NE1000, NE2000 & compatible
Device: eth0
IRQ: 10
IO: 0x0300
others:blank

Select Apply

Gives bug message:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8517830>
hw: <netconfpkg.HardwareList.Hardware instance at 84d4fe0>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 8491a48>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84f9d40>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 84fbf78>, 
<netconfpkg.HardwareList.Hardware instance at 84d4fe0>]

(Win98SE installation OK; can attached to the network.)

Note: I was assigned to evaluate various Linux distributions. One is RedHat
Comment 2 Harald Hoyer 2002-10-02 06:31:48 EDT
Workaround for now, add to /etc/modules.conf:
options eth0
Comment 3 Harald Hoyer 2002-10-18 11:47:58 EDT

*** This bug has been marked as a duplicate of 65073 ***
Comment 4 Harald Hoyer 2002-10-23 05:58:17 EDT
first beta of erratum for 7.3/7.2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.