Bug 65073 - TB NCHardwareList:288:save KeyError: options
Summary: TB NCHardwareList:288:save KeyError: options
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 66487 66578 68546 71431 71503 71551 74417 (view as bug list)
Depends On:
Blocks: rcn-7.3
TreeView+ depends on / blocked
 
Reported: 2002-05-16 23:13 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 08:43:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the content of the exception window (1.17 KB, text/plain)
2002-05-16 23:14 UTC, Need Real Name
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:257 high SHIPPED_LIVE Updated redhat-config-network package available 2003-05-06 04:00:00 UTC
Red Hat Product Errata RHBA-2002:267 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-02-07 15:19:58 UTC

Description Need Real Name 2002-05-16 23:13:29 UTC
Description of Problem:

In NEAT, when I click APPLY button (in main window) after a configuration of a
ne module for a new card I get this (on a "Eception occurred" window):

 Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Version-Release number of selected component (if applicable):
redhat-config-network-1.0.0-1

How Reproducible:

Try to add a ned card with module ne.

Steps to Reproduce:
1. Open NEAT
2. click Add
3. Coinfigure a ne1000 or ne2000 card with your settings.
4. Click "apply"

Actual Results:
The exception window with the text above.

Expected Results:
A saved configuration ... maybe. :)


Additional Information:
I don't tried this with another computer and another card so ... maybe it's
specific ...	I don't know.

Comment 1 Need Real Name 2002-05-16 23:14:55 UTC
Created attachment 57666 [details]
the content of the exception window

Comment 2 Need Real Name 2002-05-21 08:58:55 UTC
This was happend with me too.
My card is an ISA NE2000 compatible.

Maurmcio Estudier / BRASIL

Comment 3 Need Real Name 2002-05-31 21:08:15 UTC
Hello, it seems that the crash appens only when you pass parameters for the card
(IO, MEM, IRQ, etc ...). It's hardware indipendent (I tryed with a PCI card) and
it will prevent the installation of any NIC that requires configuration parameters.

Comment 4 Harald Hoyer 2002-06-26 12:40:35 UTC
*** Bug 66487 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2002-06-26 16:05:28 UTC
fixed in CVS

Comment 6 Harald Hoyer 2002-07-11 08:43:19 UTC
*** Bug 68546 has been marked as a duplicate of this bug. ***

Comment 7 Harald Hoyer 2002-10-18 15:47:48 UTC
*** Bug 66578 has been marked as a duplicate of this bug. ***

Comment 8 Harald Hoyer 2002-10-23 09:56:00 UTC
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Comment 9 Harald Hoyer 2002-11-04 12:43:11 UTC
*** Bug 71551 has been marked as a duplicate of this bug. ***

Comment 10 Harald Hoyer 2002-11-20 17:56:50 UTC
*** Bug 74417 has been marked as a duplicate of this bug. ***

Comment 11 Harald Hoyer 2002-11-20 17:57:09 UTC
*** Bug 71431 has been marked as a duplicate of this bug. ***

Comment 12 Harald Hoyer 2002-11-20 17:58:56 UTC
*** Bug 71503 has been marked as a duplicate of this bug. ***

Comment 13 John Flanagan 2003-02-14 21:04:17 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html



Note You need to log in before you can comment on or make changes to this bug.