Bug 666602 - `an error occurred, please try again later` while opening random videos
Summary: `an error occurred, please try again later` while opening random videos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnash
Version: 14
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Hicham HAOUARI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-01 11:33 UTC by udo
Modified: 2011-03-29 05:35 UTC (History)
6 users (show)

Fixed In Version: gnash-0.8.9-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-18 03:59:42 UTC


Attachments (Terms of Use)

Description udo 2011-01-01 11:33:38 UTC
Description of problem:
`an error occurred, please try again later` while opening random videos by right-clicking on the youtube URLs and opening these in a new TAB in firefox.

Version-Release number of selected component (if applicable):
gnash-plugin-0.8.8-4.fc14.x86_64

How reproducible:
See above

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
`an error occurred, please try again later` in the video area

Expected results:
video playing

Additional info:

Comment 1 udo 2011-01-01 15:38:01 UTC
ERROR: Couldn't find Method "onYouTubePlayerReady"
ERROR: Couldn't find Method "reportFlashTiming"
ERROR: Couldn't find Method "reportTimingMaps"
ERROR: Couldn't find Method "onYouTubePlayerReady"

The YouTube references do look like they could be of help to you.

After googlin' a bit I get the impression that the `Couldn't find Method "onYouTubePlayerReady"` is a common problem. Can we help to get this fixed?

Comment 2 udo 2011-01-01 15:50:19 UTC
Found some info at http://gnashdev.org/?q=node/77
So I deleted some cookies. Restarted firefox. Tried again.
The browser shows no progress.

Comment 3 udo 2011-01-01 16:12:40 UTC
Deleting the youtube cookies and then ALSO blocking youtube cookies appears to help the situation.
Clicking on uploaded videos on a yt user's page does not work, but opening these links in a new tab does play the video. (!?)

Why oh why?

Comment 4 udo 2011-01-04 17:28:03 UTC
See http://overthepeak.com/wordpress/
The vimeo video does not show here. Blank area.

ERROR: Too many attempts to read from the player!
ERROR: Couldn't find Method "AudioPlayer.getVolume"
ERROR: Couldn't find Method "onWPPlayerReady"
ERROR: Couldn't find Method "AudioPlayer.getVolume"
ERROR: Couldn't find Method "AudioPlayer.getVolume"
ERROR: Couldn't find Method "onWPPlayerReady"
ERROR: Couldn't find Method "onWPPlayerReady"
ERROR: Couldn't find Method "AudioPlayer.activate"
ERROR: Couldn't find Method "AudioPlayer.onStop"
ERROR: Couldn't find Method "AudioPlayer.activate"
ERROR: Couldn't find Method "AudioPlayer.onStop"
ERROR: Couldn't find Method "AudioPlayer.activate"
ERROR: Couldn't find Method "AudioPlayer.getVolume"
ERROR: Too many attempts to read from the player!
ERROR: Couldn't find Method "onWPPlayerReady"

Same sort of issue?
Which cookies? What workarounds?

Please notice the CPU-consumption, that is bad for the CO2.
Please do not show ads overlaying my videos. That wasted CPU, bad for CO2.

Comment 5 udo 2011-01-05 09:24:01 UTC
http://www.youtube.com/user/silverfuturist videos do not play at all and I do not see errors in .xsession-errors, so is this a new type of issue?

Comment 6 udo 2011-01-05 16:08:14 UTC
http://video.yahoo.com/watch/8694414/23705197 doesn't play. No errors, same issue?

Comment 7 udo 2011-01-06 15:00:44 UTC
So why don't the silverfuturist videos play via the user page but they do play if I find them via a search on the video title.
So what is going wrong?

Gnash eats CPU, is tricky with cookies, doesn't play all vids, and we also have a flash-plugin/nspluginwrapper issue (main reason to try gnash).

So Fedora 14 did not improve my web experience at all...

Comment 8 udo 2011-01-06 16:40:42 UTC
While playing youtube vid from Max Keiser through his  website I noticed the video/audio stutter while starting the vid and these messages appeared in .xsession-errors:
ERROR: Couldn't find Method "setAfvCompanionVars"
ERROR: Couldn't find Method "showAfvCompanionAdDiv"
ERROR: Couldn't find Method "setAfvCompanionVars"
ERROR: Couldn't find Method "showAfvCompanionAdDiv"

These must be related.

Comment 9 udo 2011-01-08 12:00:45 UTC
streeview content as well as user photo's are not displayed in maps.google.com. No errors are generated  as far as I could discover.
So is this the same issue?
or do we reopen an older bug where stuff didn't work?

Comment 10 Kevin Kofler 2011-01-08 20:40:10 UTC
For YouTube, the cookie handling only works with some browsers (e.g. the latest Firefox), for the others you have to block cookies as you already discovered.

The Yahoo! Video issue is probably completely different. Most likely, the player there relies on a newer ActionScript which is not supported by Gnash. Try Lightspark.

Comment 11 udo 2011-01-09 06:00:10 UTC
What is  considered 'latest' Firefox?
What about the other issues reported here?
Are they related or somewhat different?

Comment 12 Fedora Admin XMLRPC Client 2011-01-29 22:03:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 13 Fedora Admin XMLRPC Client 2011-01-29 22:04:43 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 14 Hicham HAOUARI 2011-02-19 01:44:29 UTC
The blank videos linked are avm2, which isn't supported by gnash.

The silverist video play via the main search function because in that case youtube looks for gnash string in flash player identification and provides the legacy player, unlike when you are in a channel.

As of the cookies issue, this shouldn't happen with current 0.8.8 release. Did you try a clean firefox profile ?

firefox -ProfileManager

then create a new profile and log with it. Make sure that all addons are disabled.

Comment 15 udo 2011-02-19 10:24:29 UTC
Thanks for clarifying blank vids.
Can you add logging for unsupported vids so we know what is wrong?

What about the silverfuturist youtube vids? I guess this is a very common case, so I deduce this must be supported real soon now.

I blocked cookies as written in some mini-howto I found.
That didn't help.
I did not explore the profile route. What can this influence?

Currently the 64-bit adobe flash works fine.

When will there be a new release I can try?

Comment 16 Raphael Groner 2011-02-19 11:46:56 UTC
Thanks for adding me to the CC list.

I guess it was done due to my other bug reports against gnash and some pages are not working with it. Sometimes, only a black box is visible, besides this nasty message "an error occured". Although, I don't think that this is a real bug, maybe more like a collection of feature requests. Why is it on severity urgent?

Also look at the other closed bug reports with "NEXTRELEASE" or "not supported" hint. Therefore, I would also appreciate a list of (reference) web pages that should work with gnash, e.g. youtube, etc.

https://bugzilla.redhat.com/show_bug.cgi?id=675042

Comment 17 udo 2011-02-19 12:15:42 UTC
Severity urgent:
After upgrading to Fedora 14 I expierenced various issues, and flash was one of them. (adobe flash!)
Flash is a mayor part of the content we enjoy so when flash didn't work it was disastrous.
So I tried various workarounds and I thought that the one open and free version would be the best solution.
And yes, it worked, sometimes. But also it had issues. It ate CPU, didn't work in the most needed spots, etc.
So yes, there is a BIG need for a better working gnash. 

Feature requests?
I don't think so.
Maybe this backgrounds that we get help, but I guess that the support for the youtube-like situations is a *must* *have*. So not a feature request. At most a feature that is not-yet implemented and perhaps not so much documented as such but very much needed.

And yes, I'd like to help make gnash better although I cannot program that much.
Can a donation help, besides testing for bugs?
References? See the ones that I posted. Simple youtube user pages.

Comment 18 Hicham HAOUARI 2011-02-19 19:25:23 UTC
(In reply to comment #16)
> Thanks for adding me to the CC list.
> 
> I guess it was done due to my other bug reports against gnash and some pages
> are not working with it. Sometimes, only a black box is visible, besides this
> nasty message "an error occured". Although, I don't think that this is a real
> bug, maybe more like a collection of feature requests. Why is it on severity
> urgent?

I think I was clear on the other bug report, avm2 videos are not supported by gnash and there is nothing we can do about them in fedora. Lightspark ( hopefully ) should handle these.

> 
> Also look at the other closed bug reports with "NEXTRELEASE" or "not supported"

The NEXTRELEASE bugs were filed against 0.8.7 and are fixed in 0.8.8. Even if they are closed, anybody is welcome to reopen them if the bug isn't fixed.

> hint. Therefore, I would also appreciate a list of (reference) web pages that
> should work with gnash, e.g. youtube, etc.
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=675042


The (reference) web pages are at : http://wiki.gnashdev.org/ExternalFlashMovies

Thanks for helping.

Comment 19 Hicham HAOUARI 2011-02-19 19:28:44 UTC
(In reply to comment #17)
> Severity urgent:
> After upgrading to Fedora 14 I expierenced various issues, and flash was one of
> them. (adobe flash!)
> Flash is a mayor part of the content we enjoy so when flash didn't work it was
> disastrous.
> So I tried various workarounds and I thought that the one open and free version
> would be the best solution.
> And yes, it worked, sometimes. But also it had issues. It ate CPU, didn't work
> in the most needed spots, etc.
> So yes, there is a BIG need for a better working gnash. 
> 
> Feature requests?
> I don't think so.
> Maybe this backgrounds that we get help, but I guess that the support for the
> youtube-like situations is a *must* *have*. So not a feature request. At most a
> feature that is not-yet implemented and perhaps not so much documented as such
> but very much needed.
> 
> And yes, I'd like to help make gnash better although I cannot program that
> much.
> Can a donation help, besides testing for bugs?
> References? See the ones that I posted. Simple youtube user pages.

To donate to gnash : http://www.openmedianow.org/?q=node/32


Other ways of getting involved : http://www.gnu.org/software/gnash/get-involved.html

Comment 20 Raphael Groner 2011-02-19 21:00:43 UTC
Hint @ udo: Try Midori. I can see all those youtube videos with Midori, though only a message "an error occured" is visible with Firefox.

firefox-3.6.13-1.fc14.x86_64
midori-0.3.0-2.fc14.x86_64
webkitgtk-1.3.10-1.fc14.x86_64
gnash-0.8.8-4.fc14.x86_64


About the javascript issues, I'll test with Lightspark and report bugs against the other package.

I agree that Fedora can nothing do directly in case of upstream bugs.


Removal of AVM2 in Gnash 0.8.8 … http://benjaminwolsey.de/node/94
Also take a look here: http://www.pledgebank.com/gnash-avm2

Comment 21 Fedora Update System 2011-03-13 16:53:20 UTC
gnash-0.8.9-0.1.20110312git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc14

Comment 22 Fedora Update System 2011-03-13 16:55:54 UTC
gnash-0.8.9-0.1.20110312git.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc13

Comment 23 Fedora Update System 2011-03-13 16:58:24 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc15

Comment 24 Fedora Update System 2011-03-18 03:57:11 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2011-03-19 02:15:06 UTC
gnash-0.8.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc14

Comment 26 Fedora Update System 2011-03-19 02:22:32 UTC
gnash-0.8.9-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc13

Comment 27 Fedora Update System 2011-03-27 19:24:45 UTC
gnash-0.8.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2011-03-27 19:32:16 UTC
gnash-0.8.9-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 collura 2011-03-28 08:28:16 UTC
still getting 'An error occurred, please try again later.' with:

firefox-3.6.16-1/f14 (x86_64)
gnash-1:0.8.9-1.fc14 (x86_64)

Comment 30 collura 2011-03-28 09:14:24 UTC
oh, and regarding comment#20:

http://wiki.gnashdev.org/List_of_Tasks
>AVM2 Compatibility
>
>Petter Reinholdtsen started a pledge on http://www.pledgebank.com/gnash-avm2 to >try to raise funding to get AVM2 support into Gnash, and it is open until >December 24th, 2010. As he succeeded in raising the $1400USD that was his goal, >now we're looking for someone to sign up for this task.

Comment 31 Hicham HAOUARI 2011-03-28 23:52:26 UTC
@collura :

Did you remove youtube cookies ?

Comment 32 collura 2011-03-29 05:35:01 UTC
rats related to an different issue with addon i think. 

yes i removed cookies as best as i know (tools-clearrecenthistory-everything) but it looks like what it got stuck on was the noscript addon?

the noscript addon set to 'temporarily allow all this page' seemed to clear things so that no 'an error occurred please try again later' error though didnt have ffmpeg installed on the test machine so just get a nice missing codec error so didnt see video as marker moved along bottom of screen and when finished the next suggested video choices popped up as expected.

*interesting that individually allowing each site of the page in noscript did not produce the same result as 'temporarily allow all this page'.

also then go to next video it seems like i did have to delete all cookies again to get that one to play.

so guess this bug stays closed.


Note You need to log in before you can comment on or make changes to this bug.