Bug 666637 - [Bug] Cannot input accented characters in QT-[3,4] applications
[Bug] Cannot input accented characters in QT-[3,4] applications
Status: CLOSED DUPLICATE of bug 658090
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-01 13:39 EST by Gian Paolo Mureddu
Modified: 2011-01-01 19:42 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-01 19:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2011-01-01 13:39:40 EST
Description of problem:
Problems with text input in QT 3 and 4 applications with accented characters, example: when writing text instead of á I get 'a, é I get 'e, etc. It also applies to inverted accent, such as à, è, ù which yield `a, `e and `u, or other types of accents such as ü which does not yield the character (" is usually what you get), circumflex characters are also affected instead of â I see ^a... What I see happens is that QT applications do not wait for the character to be finished... I.e, when pressing the accent key instead of finishing the "stroke" when pressing the vowel key like in pressing ['] and then [a] for á, the accent is immediately printed to the screen in QT apps (I'm sorry if I'm not being very clear, that's as best sa I can to explain what it happens). Also I'm not sure if this only happens with QT as shipped in Fedora 14 or if it also happens with QT in other versions of Fedora (like 13 or 12), but it happens with QT 4 and 3 applications (for example, Scribus, Calibre or K3B).

Version-Release number of selected component (if applicable):

qt3-3.3.8b-30.fc14.x86_64
qt-4.7.1-5.fc14.x86_64

How reproducible:

Always

Steps to Reproduce:

1. Install a QT application and change your keyboard to a latin layout (Spanish, Portuguese, Italian or French, etc)
2. Try to input accented characters in such applications and see what happens.
  
Actual results:

The accents are printed to the screen before the full character is typed.


Expected results:

The text input fields to wait for the full character to be typed. Affected applications are all with text input fields.

Sorry if this has already been reported, I couldn't find any reference to bugs concerning this with QT (that or my search skills really lack)
Comment 1 Kevin Kofler 2011-01-01 13:45:06 EST
See bug 468590 and bug 658090. This is very likely to be a duplicate of one or the other (unless they're really both the same, which is also unclear).
Comment 2 Gian Paolo Mureddu 2011-01-01 14:26:21 EST
I have read both bug reports, and while the behaviour seems to be virtually the same, I think it has more to do with the behaviour exposed in bug #468590. I don't have scim installed, I'm using these QT apps from GNOME in F14 in an "international" environment (Es-MX locale), I do have the iBus input chooser loaded by default as I have the need to input special characters often, which has never had any problems with it in OOo. With previous versions of Fedora I had not the need to use Scribus from GNOME, so I can't say if this bug was still present there. I do think it may have something to do with some configuration options. Worth noting that this is installation of Fedora 14 is actually an upgrade from Fedora 13 (which may have some configuration options lingering in the wrong place or some such).
Comment 3 Gian Paolo Mureddu 2011-01-01 16:12:55 EST
Just tested this problem within KDE itself, I still see the problem even there. Actually the session settings from GDM don't stick when entering the KDE session, instead of Es-MX (Mexico), KDE selected my locale as Es-ES (Spain). Despite that, in every text-input field I still got the problem with (what now I know are "deadkeys") accented character input. This more than anything mihgt suggest that indeed there is a configuration problem with QT and the way Fedora might ship the packages, now to narrow where the problem actually lies is what I'm interested in. Sadly for me peforming a "fresh" install (i.e fully format my root partition) is not feasible, and I'm not sure if the problems will still be there as I wouldn't format my home partition (hence some parts of the misconfiguration might still be there).
Comment 4 Kevin Kofler 2011-01-01 19:42:55 EST
Bug 468590 is with SCIM, bug 658090 is with IBus, that's the only visible difference between the 2 bugs (so they may actually be the same). I'm closing this report as a duplicate of the IBus one.

*** This bug has been marked as a duplicate of bug 658090 ***

Note You need to log in before you can comment on or make changes to this bug.