Bug 658090 - Cannot input accented characters in Qt applications when using IBus
Cannot input accented characters in Qt applications when using IBus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
13
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 666637 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 05:42 EST by nomnex
Modified: 2011-03-13 22:12 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-13 22:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nomnex 2010-11-29 05:42:02 EST
Description of problem:

There is not input of the circumflex accent 'ê/Ê' with the Swiss-French input layout when I create French vocabulary card.

The bug must be related to QT (it affects LyX, Scribus -- all using QT).

I use a Japanese keyboard (notebook) with an English OS. Defaut inputs are English/Swiss-French.


Version-Release number of selected component (if applicable):

Anki 1.0.1 (QT-X11 4.6.3) on Fedora 13 LXDE

How reproducible:

Change keyboard layout to Swiss-French and type '^+e'


Steps to Reproduce:
1.
2.
3.
  
Actual results:

^e

Expected results:

ê

Additional info:

I have previously reported this bug on Anki, see: http://code.google.com/p/anki/issues/detail?id=2117

and a bug on QT, see: http://bugreports.qt.nokia.com/browse/QTBUG-15691

The Anki developer nicely advised me to open a bug on my distribution in the fist place.

"contact the Fedora maintainer of Anki - since he has access to the latest Fedora, he may be able to test this for you easily."
Comment 1 Christian Krause 2010-12-12 12:16:06 EST
I can't reproduce the problem. My test setup was:

- Germany keyboard
- chosed "Switzerland French" keyboard layout:
* in the Gnome "Keyboard Preferences" dialog: I've chosen Country: Switzerland, Vairant: "Switzerland French"
* be sure _not_ to select "Switherland French, elmininate dead keys"

Please can you re-test?
Comment 2 nomnex 2010-12-12 19:08:15 EST
Looks like I am deep water.

There is not applet to switch the keyboard layout on LXDE F-13, as in Gnome.  (well, there is, but the second keyboard layout has to be set manually...)

my default layout is language US/keyboard JPN.

additional layout was set with the following command:

setxkbmap -layout "jp,ch(fr)" -option "grp:alt_shift_toggle"

$ setxkbmap -print (detail):

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"	};
        xkb_compat    { include "complete"	};
        xkb_symbols   { include "pc+jp+ch(fr):2+inet(evdev)+group(alt_shift_to$
        xkb_geometry  { include "pc(pc104)"     };
};

most likley something must be going on with QT (could it be QT alone interprets my keyboard setting as 'eliminate dead keys'?).  Any GTK+ application, FF, OOo, etc. translate all the accents correctly.  QT does with most of the accents, but the 'ê'.  I encounter this problem on Anki, Scribus and Lxy.
Comment 3 Christian Krause 2010-12-13 15:09:59 EST
Ok, since it also happens for all other QT applications, I agree that the problem is located in the qt libraries itself. I'll re-assign the CR to the QT packagers.
Comment 4 Kevin Kofler 2010-12-13 15:16:18 EST
Are you using SCIM? If so, it's a duplicate of bug 490841. (Try IBus instead.)
Comment 5 Kevin Kofler 2010-12-13 15:17:22 EST
(Actually a duplicate of bug 468590. Bug 477552 and bug 490841 are duplicates.)
Comment 6 nomnex 2010-12-13 20:18:19 EST
Kevin, isn't it a bit hasty to make the bug as duplicate before I answer your question? The bug links relates similar issues with 'accent with dead key' using SCIM (on GNOME/KDE). Do you confirm the validity of the bug marking, even though I am using IBUS (on LXDE) and not SCIM. Thank you.
Comment 7 Kevin Kofler 2010-12-14 01:38:32 EST
I didn't mark the bug as a duplicate.

This is the first report of that issue with IBus that I'm aware of. According to the feedback in https://bugs.kde.org/show_bug.cgi?id=180506 , at least one person who encountered bug 468590 with SCIM had the bug go away by switching to IBus.

I wonder if anything changed recently in IBus which broke this.
Comment 8 nomnex 2010-12-14 02:16:48 EST
oh, my bad. I should have given more attention to bug status.

I am a bit skeptical on this. I-bus works perfectly but with applications using the QT-4 toolkit.

I have another notebook lying around. I have installed F14 + anki, lxy, etc. to make sure. Same output: Shift + 4 output 'ç' correctly. All the other French accents are also correctly mapped, but the caret + e 'ê' renders a '^e'.

Is there anything I can do (at the limit of my competence) to help troubleshooting the issue?
Comment 9 Denis Dzyubenko 2010-12-20 06:44:23 EST
I've commented on a Qt bugreport http://bugreports.qt.nokia.com/browse/QTBUG-15691:

Please provide more info.

I've tried to reproduce it in Ubuntu 10.10 Maverick with Qt 4.7 and ibus - I've installed ibus packages (ibus and ibus-pinyin and ibus-qt4 (which I've recompiled myself for Qt 4.7). Then I've executed "im-switch -s ibus" and re-logined.

Then I've launched textedit demo application and made sure I am using ibus input method by right clicking in the text field and checking the "Input method" popup menu.

Then I switched my keyboard layout to "Switzerland French" and pressed "^" and then "e" and got "ê" as a result, as expected.

My QT_IM_MODULE environment variable is set to "ibus", I've also tried to reproduce the problem with xim input method, but it also works fine there
Comment 10 Kevin Kofler 2011-01-01 19:42:55 EST
*** Bug 666637 has been marked as a duplicate of this bug. ***
Comment 11 nomnex 2011-01-05 03:30:01 EST
Denis, this is the copy of my answer to your comment on the Qt bugreport, for information (see: comment 9).

Denis, sorry to answer your comment late:

Some (hopefully) relevant point to this bug report.

personal first: I don't use Ubuntu anymore more since the bug Intel 855 GPU (Fedora is the only distribution, to my knowledge, to include a 'drm-intel-big-hammer.patch.' It installs correctly on my computers). The 'how to 855 GPU' available on the Ubuntu wiki did not help, and my installations were unstable (black screen, freeze and crash). So for the time being I cannot try another distribution as you suggested.

Secondly, for the same reasons -- low spec PC -- (and because I don't like bloated OS with bells and whistles), I have moved from Gnome to LXDE (the Fedora spin). Denis, and other people answered with a positive 'it works' comment, but they/you are all using Gnome.

May I ask if any of you --Qt dev-- could give it a try with a LXDE spin (Fedora)? Because I wonder if the problem is not specific to QT + LXDE?

I can not bring much technical input, but I would suppose the problem lies somewhere between the interaction of the DE and QT (if it make sens?) since I can use the 'ê' dead key with any other application, but the applications relying on Qt.

Qt version in Fedora 13 LXDE is Qt 4.6.3
Qt version in Fedora 14 LXDe is Qt 4.7.1

Neither of the computers running F13 LXDE, or F14 LXDE can use the dead key 'ê' when I select Swiss-French input and when I use a Qt application.

nomnex.
Comment 12 nomnex 2011-03-13 21:49:36 EDT
the bug has been addressed by one of the update of my distribution. the 'ê' (circumflex on the letter e, using the dead key) now works.

still Qt version 4.6.3 here

Note You need to log in before you can comment on or make changes to this bug.